Find the answer to your Linux question:
Results 1 to 9 of 9
Hello, I've been having a weird problem lately with Fedora 17. Whenever I boot the computer the wireless is turned off. I'm using Gnome 3 and so I can simply ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2012
    Posts
    29

    Crash after turning on wireless Bug


    Hello, I've been having a weird problem lately with Fedora 17. Whenever I boot the computer the wireless is turned off. I'm using Gnome 3 and so I can simply toggle the switch in the upper right hand corner where the wireless is to turn the wireless on. Whenever I toggle the switch however the computer simply freezes and stays like that for a long time. I then must hard shutdown my computer (using the powe-button) and then reboot it. Only then can I toggle that stupid wireless switch and the computer won't freeze. Does anybody know what's causing this? And what is the way to turn the wireless on (and it isn't ifconfig wlan0 up) in terminal so I can avoid this?

  2. #2
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,317
    Assuming your wireless device is indeed "wlan0", is networking enabled (ONBOOT=yes) in this file?

    /etc/sysconfig/network-scripts/ifcfg-wlan0

    Not sure about your desktop freezing - that sounds like a bug to me. Have you run updates?

  3. #3
    Just Joined!
    Join Date
    Mar 2012
    Posts
    29
    Funny thing: ifcfg-wlan0 doesn't exist anywhere on my box - however if my wireless was on before shutdown then when I boot it's turned on. As far as the desktop freezes: I figured out that it only happens when I re-enable my wireless card and then try and turn it on. If you know what the CLI command equivalent for the GUI wireless switch is I might be able to figure out what's going on. Is there a way that I can report a bug without using the arbrt bug reporting program? I can't officially report the problem because I have to force shutdown when it occurs - removing any way for abrt to detect there was a problem.

  4. #4
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,317
    I do not know the CLI equivalent for that, sorry. I don't have a desktop machine w/wireless running on F17.

    Perhaps it has something to do w/NetworkManager. That package is responsible for "smart" networking: it will flip from one network adapter to another, like if you are wired in, but it detects a wireless connection, etc. You can try using the conventional "network" service, instead of NetworkManager, if you don't mind losing this feature.

    turn off NM:
    Code:
    systemctl stop NetworkManager
    disable NM:
    Code:
    systemctl disable NetworkManager
    enable network script:
    Code:
    chkconfig network on
    start network script:
    Code:
    service network restart
    but you'll have to make sure that your ifcfg-wlan0 configuration file exists and is fully populated w/relevant info, or it won't work.

    if that doesn't work, it is simple to re-enable NM:
    Code:
    systemctl enable NetworkManager

  5. #5
    Just Joined!
    Join Date
    Mar 2012
    Posts
    29
    I will try that asap....however you did state that i need to have ifcfg-wlan0 - which I don't. What is the file for and how do I obtain it (or what information do I need to write to it if that is necessary?). Thanks!

  6. #6
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,317
    you can cobble it together fairly easily. look at one of the other ifcfg-* files in there and copy the info. what you NEED to set is something like:

    Code:
    DEVICE="wlan0"
    NM_CONTROLLED="no"
    IPADDR="192.168.1.4"
    GATEWAY="192.168.1.1"
    HWADDR="00:00:22:BB:44:FF"
    NETMASK="255.255.255.0"
    BOOTPROTO="static"
    ONBOOT="yes"
    DNS1="1.2.3.4"
    DNS2="1.2.3.5"
    #ETHTOOL_OPTS_OFFLOAD=""
    KEY=123abc
    ESSID=yournetworkessid

  7. #7
    Just Joined!
    Join Date
    Mar 2012
    Posts
    29
    I apologize for the late response however I did find something interesting. First I went into terminal and did
    Code:
    ifconfig wlan0 down
    This didn't seem to work (in that the gnome icon at the upper right part showed my wireless was still enabled). So I pressed the button on my laptop to turn off the wireless. Then in terminal I sent:
    Code:
     ifconfig wlan0 up
    After pressing carriage return my computer froze and recreated the problem. Any ideas?

  8. #8
    Just Joined!
    Join Date
    Oct 2012
    Posts
    15
    I had the same problem. Guide me as well if any one know the solution.

  9. #9
    Just Joined!
    Join Date
    Mar 2012
    Posts
    29
    Quote Originally Posted by qualitynet View Post
    I had the same problem. Guide me as well if any one know the solution.
    To be honest I am not sure what the problem was. It seemed to have only occured when I was using the GNOME 3 GUI, however I have switched to XMonad and since haven't ran into the problem.

    I will post the solution if I can replicate the problem.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •