Find the answer to your Linux question:
Results 1 to 5 of 5
I'm trying to get my fedora 17 box to connect to a wifi network that uses passwords. If I'm reading the man page right, I should be able to do ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! rm-rf's Avatar
    Join Date
    Mar 2011
    Posts
    85

    How do I get nmcli to connect to a wireless network?


    I'm trying to get my fedora 17 box to connect to a wifi network that uses passwords. If I'm reading the man page right, I should be able to do
    Code:
    nmcli dev wifi connect <network> <password>
    but that keeps giving me errors.

  2. #2
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    1. Is NetworkManager running?

    2. Are you running nmcli as root?

    3. Can you post the errors you are getting?

  3. #3
    Just Joined!
    Join Date
    Oct 2012
    Posts
    15
    Run nmcli as root. it will work for you.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined! rm-rf's Avatar
    Join Date
    Mar 2011
    Posts
    85
    Nevermind I fixed it. It turns out you need to litterally type in the word "password". eg.
    Code:
    nmcli dev wifi connect <name> password <password>
    and no I don't need to run it as root.

  6. #5
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    Glad you got is sorted. Marking as Solved.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •