Find the answer to your Linux question:
Results 1 to 5 of 5
Ubuntu 12.04 custom remix with repackaged 3.5 kernel and lots of custom security. Everything looks as if it should work. I probably borked something somewhere along the way. But, it ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux User Steven_G's Avatar
    Join Date
    Jun 2012
    Location
    Western US
    Posts
    325

    Can't connect Intel N-1000 Wireless / Ubuntu 12.04


    Ubuntu 12.04 custom remix with repackaged 3.5 kernel and lots of custom security. Everything looks as if it should work. I probably borked something somewhere along the way. But, it must be deep because I can't find it.

    I can see wireless networks around me. When I try to connect to a secure network I just time out with no error messages and just keep auto retrying to connect forever and it keeps asking me for the password over and over again. (Yes I have verified the password is correct).

    On an unsecure network I just time out with “Wireless network diconnected” message.

    This same custom UB remix is working just fine on another machine with a broadcom card in it. I just had to put the right driver in it.

    I'm wondering if maybe this is a group permission error? I've noticed that with the installable copy of my remix that I made with remastersys it did not set the groups up correctly when I moved to new hardware. I had to go back manually and do a lot of stuff. Did I miss something:
    Code:
    id 
    uid=1000(adam) gid=1000(adam) groups=1000(adam),4(adm),20(dialout),21(fax),24(cdrom),25(floppy),26(tape),27(sudo),30(dip),44(video),46(plugdev),104(fuse),108(lpadmin),109(sambashare),113(netdev),122(bind),123(vboxusers),1001(jupiter),1002(bumblebee)
    This is the outputs on the card:
    Code:
    sudo lshw
    …....
    Code:
    network 
                    description: Wireless interface 
                    product: Centrino Wireless-N 1000 
                    vendor: Intel Corporation 
                    physical id: 0 
                    bus info: pci@0000:03:00.0 
                    logical name: wlan0 
                    version: 00 
                    serial: XX:XX:XX:XX:XX:XX 
                    width: 64 bits 
                    clock: 33MHz 
                    capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless 
                    configuration: broadcast=yes driver=iwlwifi driverversion=3.5.0-23-generic firmware=39.31.5.1 build 35138 latency=0 link=no multicast=yes wireless=IEEE 802.11bgn 
                    resources: irq:55 memory:f1b00000-f1b01fff
    ........

    Code:
    lspci
    …...
    Code:
    03:00.0 Network controller: Intel Corporation Centrino Wireless-N 1000
    ......

    Code:
     iwconfig
    eth0      no wireless extensions. 
    
    lo        no wireless extensions. 
    
    wlan0     IEEE 802.11bgn  ESSID:off/any  
              Mode:Managed  Access Point: Not-Associated   Tx-Power=14 dBm   
              Retry  long limit:7   RTS thr:off   Fragment thr:off 
              Power Management:off
    Code:
    sudo iwlist scan
    Shows all the wireless networks in my area.

    Code:
    rfkill list
    0: phy0: Wireless LAN 
    	Soft blocked: no 
    	Hard blocked: no
    Code:
    iwlist chan 
    eth0      no frequency information. 
    
    lo        no frequency information. 
    
    wlan0     13 channels in total; available frequencies : 
              Channel 01 : 2.412 GHz 
              Channel 02 : 2.417 GHz 
              Channel 03 : 2.422 GHz 
              Channel 04 : 2.427 GHz 
              Channel 05 : 2.432 GHz 
              Channel 06 : 2.437 GHz 
              Channel 07 : 2.442 GHz 
              Channel 08 : 2.447 GHz 
              Channel 09 : 2.452 GHz 
              Channel 10 : 2.457 GHz 
              Channel 11 : 2.462 GHz 
              Channel 12 : 2.467 GHz 
              Channel 13 : 2.472 Ghz
    Code:
    dmesg | grep iwl 
    [   21.056760] iwlwifi: Intel(R) Wireless WiFi Link AGN driver for Linux, in-tree: 
    [   21.056763] iwlwifi: Copyright(c) 2003-2012 Intel Corporation 
    [   21.056913] iwlwifi 0000:03:00.0: pci_resource_len = 0x00002000 
    [   21.056915] iwlwifi 0000:03:00.0: pci_resource_base = ffffc90006864000 
    [   21.056917] iwlwifi 0000:03:00.0: HW Revision ID = 0x0 
    [   21.057295] iwlwifi 0000:03:00.0: irq 55 for MSI/MSI-X 
    [   21.194787] iwlwifi 0000:03:00.0: loaded firmware version 39.31.5.1 build 35138 
    [   21.194922] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEBUG disabled 
    [   21.194925] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEBUGFS enabled 
    [   21.194926] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEVICE_TRACING enabled 
    [   21.194928] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEVICE_TESTMODE enabled 
    [   21.194929] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_P2P disabled 
    [   21.194931] iwlwifi 0000:03:00.0: Detected Intel(R) Centrino(R) Wireless-N 1000 BGN, REV=0x6C 
    [   21.195012] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S 
    [   21.202327] iwlwifi 0000:03:00.0: RF_KILL bit toggled to enable radio. 
    [   21.216371] iwlwifi 0000:03:00.0: device EEPROM VER=0x15d, CALIB=0x6 
    [   21.216375] iwlwifi 0000:03:00.0: Device SKU: 0x50 
    [   21.216378] iwlwifi 0000:03:00.0: Valid Tx ant: 0x1, Valid Rx ant: 0x3 
    [   21.216390] iwlwifi 0000:03:00.0: Tunable channels: 13 802.11bg, 0 802.11a channels 
    [   21.220161] ieee80211 phy0: Selected rate control algorithm 'iwl-agn-rs' 
    [   22.552363] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S 
    [   22.613239] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
    Code:
    lsmod | grep iwlagn
    Returns no results, which if I understand things correctly means that the wifi driver is either not installed or not loaded. But that makes absolutely no sense because if I'm reading all of the other outputs correctly it sure looks to me like the driver is working. Not only that, but, if I'm understanding things correctly this driver has been built in to the kernel since UB 11.04. Unless there's been a regression in the kernel and I need to pull and old driver forward? But I have the linux-firmware module installed and lshw shows firmware for the card.

    According to hardinfo the info I keep finding on the net is not correct and the driver is not iwlagn? According to hardinfo the driver is iwlwifi? (Unless the wrong module is getting load for some reason?)
    Code:
    lsmod | grep iwlwifi 
    iwlwifi               399651  0 
    mac80211              555198  1 iwlwifi 
    cfg80211              208382  2 iwlwifi,mac80211
    The router does not label modes as b,g or n., but rather lists by speeds. So I set it to the lowest (54 Mbps). And the wireless access list is set to accept connections from this machines MAC. I've also made sure the password is correct.

    Arpon is set to:
    Code:
    DAEMON_OPTS="-q -f /var/log/arpon/arpon.log -g -d"
    and does not effect the other machine from connecting.

    But,
    Code:
     arp -a
    only returns
    Code:
    ? (192.168.1.1) at XX:XX:XX:XX:XX:XX [ether] PERM on eth0
    so there's only a matched pair for the wired connection and not the wireless. I think that has to do with the card and not ArpOn.

    I can connect to both the wired router connection and my subscription service remote VPN tunnel secured proxy with no issues. VM NAT networking is working fine. So it has to be some thing with the wireless card.

    Maybe it's an apparmor issue? I'm using the utils set of profiles. Which are not the same as the default profiles. But, the other machine works fine with them. I have AA set to complain. I've gotten no messages and there's nothing in the logs that stands out to me.

    I can't see anything in portsentry that should be affecting the wireless card being able to connect and the other machine works fine with it as is.

    NetworkManager.conf is pretty straight forward:
    Code:
    [main] 
    plugins=ifupdown,keyfile 
    #dns=dnsmasq 
    
    
    #no-auto-default=XX:XX:XX:XX:XX:XX, 
    
    [ifupdown] 
    managed=false
    “#no-auto-default=XX:XX:XX:XX:XX:XX, ” is set by ArpOn with the MAC of the machine I originally built this remix on. I commented it out when I moved to new hardware. ArpOn should be regenerating the same parameter with the new MAC, but is not.

    On further research the driver for this card was changed from iwlagn to iwlwifi in kernel 3.2 and people have been having problems with it running super slow due to a problem with the default parameters in the driver. I figured maybe that was stopping me from making a connection before I timed out. So I tried this fix from the web:

    Code:
    echo "options iwlwifi 11n_disable=1" | sudo tee /etc/modprobe.d/iwlwifi.conf 
    sudo modprobe -rfv iwlwifi 
    sudo modprobe iwlwifi
    That didn't work either.

    This card is supposed to work OOB since UB 11.04 (which IIRC, used kernel 2.6, which should mean that it should use the older iwlagn driver.)

    Just for poops and giggles I tried to unload the new driver module and load the old driver module (just in case it was still in linux-firmware):
    Code:
    sudo modprobe -r iwlwifi 
    sudo modprobe iwlagn
    Which didn't throw any error messages. It also didn't work either.

    I'm still learning and I saw on one fix as I searched that they updated initramfs after monkeying with modprobe:
    Code:
     sudo update-initramfs -u
    and rebooted, which did nothing.

    I've looked around the web and I cannot find a stand alone download for the old module (iwlagn).

    I'm completely out of ideas at this point. I'll keep digging. But help would be greatly appreciated.

    BTW, this is an Optimus machine. I had to hack it 97 ways to Sunday to get video working properly. A big part of that was making my own remix from a minimal / command line install. I may have left something out without realizing it. After lots of experimenting I solved the video issues by including the 3.5 kernel in my build. I really don't want to roll back to an old kernel as that will open a whole new can of worms. This machine is plugged in to a TV and I've pretty much turned it in to a desktop. But, I wanted to take it with me the other day only to find the wireless card won't connect to anything even though I'll be damned if I can figure out why.

  2. #2
    Linux User Steven_G's Avatar
    Join Date
    Jun 2012
    Location
    Western US
    Posts
    325
    OK, this is to help other people: My stuff is borked, but it's not my fault. If you're having issues with this card or with another card that runs on this driver there's a reason for it. After another 13 hours straight of research and experimentation since I last posted I've fould lots and lots of reasons this could be happening with lots and lots of fixes depending on the exact cause and the exact machine / setup. Basically what it boils down to is this driver has been fouled up for the last few iterations of the kernel. Starting with 3.2 there have been tons of changes to this driver and from what I've read every time they change something it gets worse. Supposedly it's flat out horrible in 3.8. I just finished reading some stuff by a guru saying that system calls and config functions related to this driver have been totally FUBAR'd.

    What finally worked to fix it for me was to roll my kernel back to a main line Ubuntu PPA one-off special remix of 3.1 for precise. And while that fixed my wifi it broke *everything* else. So, I'm giving up. I haven't slept in 36 hours. Something like this is waaaay beyond my current skill level to fix.

    So I guess I have a desktop now!

    If you run in to this issue all I can say is good luck and I hope you don't have an Optimus video card, you haven't added one thing to OOB sec and you don't have any hardware or software that requires a newer version of the kernel to work.

  3. #3
    Just Joined!
    Join Date
    Feb 2013
    Posts
    4
    Steven try going to the dash and type in software source and there should be a tab in there for seeing the drivers or did you try recovering unbuntu package at reboot by doing safe recover

  4. #4
    Linux User Steven_G's Avatar
    Join Date
    Jun 2012
    Location
    Western US
    Posts
    325
    *Nothing* in my system is standard. I didn't include dash on purpose. My DE is a hybrid of XFCE grafted on to the Gnome toolset without the Gnome shell. So none of my stuff is where you would expect it to be. In my software sources list there is no driver tab. However, if you're referring to the Jockey GUI / Additional Drivers then the only thing showing up in there is drivers for my Nividia; which I don't want to activate because I'm using Bumble Bee.

    The driver for this card is included in the module "linux-firmware". The driver covers more than just this card. It covers a set of cards built on the same chipset. In kernel 3.2 they merged some stuff, dumped the driver iwlagn and replaced it with iwlwifi. The new driver is causing a lot of headaches for a lot of people. The old driver is supposed to work like a charm with my particular card.

    The only thing I haven't tried yet, because I don't know how (yet), is to pull the old linux-firmware module forward. I know how to enable new stuff being pulled backwards through backports. But I haven't figured out how to pull old stuff forward without blowing up my system. I have a VM that is a perfect code level replica of my real machine. Every time I try enabling repos from UB 11.04 and pulling the firmware module forward I end up overwritting large chunks of my system causing it to go KFB.

    The next thing I'll try is to DL / install the module from ubuntuupdates.org and pin it. But I have no idea if a firmware module for the 2.6 kernel will work with the 3.5 kernel. And I'm not sure how accurate a test in a VM will be since it's not on real hardware.

    The only other two things I can think to try is to compile my own version of the 3.5 kernel with the firmware module from the 2.6 kernel. Or figuring out how to extract the old driver from the old module and drop it in to my system. Both will involve increasing my skill set.

    And no, I didn't try anything in recovery mode. I have to be very careful with recovery mode. Some (but not most) functions / tools in my dpkg and aptitude do not work in ways that you would expect. This is for a couple of reasons: 1) I used grep to intentionally "break" some dependency resolving functions so that I could deconstruct the XFCE and Gnome Desktop Environment metapackages and "graft" them together. 2) I've also "grafted" a 32bit "subsystem" to my 64bit system because I ran in to a few 32bit programs that just flat out refused to run in a 64bit environment, even with all the right libraries in place. The net result is something that I personally think is pretty cool. But it has it's quirks. I can resolv deps no problem with apt as it reads what I've put out through aptitude and thinks all is "normal" and just follows the dep chains I've built. But some tools in aptitude and the recovery console can have unexpected and unitended consequences resulting in KFB.

    And before anybody flames me for cooking up / running such a monstrosity: Well I only took the full plunge in to *nix on hardware about 9 months ago. It's my first homemade distro. The next one will be better. And none of the over the counter distros could run my hardware in the way I wanted when I got it (i.e. using a big screen TV plugged in to the DGPU as a monitor b/c I have bad eyes and I want to be able to play good games) because I fouled up and got an Optimus card. So, it might not be pretty but at least it works. And the *only* issue I've had with it is the wifi card. And as we all know every *nix distro has issues with wifi cards. So I think I did OK.
    Last edited by Steven_G; 02-13-2013 at 09:43 PM.

  5. #5
    Linux User Steven_G's Avatar
    Join Date
    Jun 2012
    Location
    Western US
    Posts
    325
    This is to help keep the next person from wasting a bunch of time chaising their tail down the wrong path like I did:

    This was not a driver issue at all.

    The give away, that I missed and should have caught, was that when I tried to connect to any wireless net I got an authenication dialog with a message stating: "System policy prevents modification of network settings for all users" and asking for my admin password.

    Chasing this led me to a bug / regression report on launchpad for Ubuntu 12.04.

    mathieu-tl, Canonical Desktop Team, stated this was no bug. It is new sec and functioning per design.

    One user stated there is a non-obvious solution: When the authentication dialog appears hit "cancel" and you can configure the connection on a per user basis.

    It turns out that I was right when I asked if it was a permissions error. One user states in reply to the bug report a list of fixes attempted to fix this for remote newtork access. I read that and got an idea which worked:

    In sudoers I changed my user permissions from:

    Code:
    <user> ALL=(ALL) ALL
    (Admin level permissions)

    to

    Code:
    <user> ALL=(ALL:All) ALL
    (Root level permissions)

    Now I can finally connect to a wireless net with no problem. And, unlike a lot of folks I am having no issue with n mode and an Intel chipset. I'm running like a screaming banshee.

    -----------
    Edit: There are some other solutions in the referred to thread and this one would not be a good idea if you have reasons for some of your users to not have unlimited privileges on your systems.
    Last edited by Steven_G; 02-22-2013 at 12:09 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •