Find the answer to your Linux question:
Results 1 to 4 of 4
Good morning/evening. [English is not my native language, sorry about any errors in spelling/grammar] I installed Ubuntu 12.04 (dual-boot with Win7) on my Laptop, I felt that my Atheros AR9285 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2009
    Posts
    4

    Atheros AR9285 - can't set txpower above 15dBm when disconnected


    Good morning/evening.

    [English is not my native language, sorry about any errors in spelling/grammar]

    I installed Ubuntu 12.04 (dual-boot with Win7) on my Laptop, I felt that my Atheros AR9285 wireless reception is lower on Ubuntu than on Win7.
    I investigated the issue and found that on Windows the txpower is 27dBm while on Ubuntu it is 15dBm.
    I tried to change it on Ubuntu using

    Code:
    sudo iwconfig wlan0 txpower 27
    but I get the error:

    Code:
    Error for wireless request "Set Tx Power" (8B26) :
        SET failed on device wlan0 ; Invalid argument.
    But if I change it to a value less than 15dBm, it changes without error.

    I found many suggestions that it is a driver limitation, but what confused me is that I could change it ONLY after I connect to my home network!
    When I'm connected, I can set txpower to 27 without error, but when I'm not connected, I can set it only to 14 or less.

    Here is the output of iwconfig before connection:

    Code:
    wlan0     IEEE 802.11bgn  ESSID:off/any  
              Mode:Managed  Frequency:2.457 GHz  Access Point: Not-Associated   
              Tx-Power=15 dBm   
              Retry  long limit:7   RTS thr:off   Fragment thr:off
              Power Management:off
    and here is after connection (and changing txpower):

    Code:
    wlan0     IEEE 802.11bgn  ESSID:"mywifi"  
              Mode:Managed  Frequency:2.457 GHz  Access Point: xx:xx:xx:xx:xx:xx   
              Bit Rate=150 Mb/s   Tx-Power=27 dBm   
              Retry  long limit:7   RTS thr:off   Fragment thr:off
              Power Management:on
              Link Quality=65/70  Signal level=-45 dBm  
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:10  Invalid misc:5   Missed beacon:0
    My wireless router is far outside my room, and I cannot connect to it on 15dBm, so I have to physically move out of my room everytime I have to connect, which is too frustrating and impractical, that's why I need the txpower to remain 27dBm even when disconnected.
    So, why is that partial limitation? how can I keep it always 27dBm whether connected or not?
    Thanks for your attention.

    *Things I tried that didn't solve the problem:
    - Disabling/enabling power management
    - Disabling ath9k hardware encryption (echo "options ath9k nohwcrypt=1" > /etc/modprobe.d/ath9k.conf)
    - Changing router mode from n/b/g to b/g
    Last edited by Drycola; 04-12-2013 at 07:28 PM. Reason: grammatical correction

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,397
    It may be that 27dbm is not a valid setting. Try others. You can also set the txpower option to mw, such as 30mw. In such a case, P (dbm) = 30 + 10log(w) - according to the iwconfig man page. There is also the possibility that Linux doesn't support multiple transmit power settings for this device...
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  3. #3
    Just Joined!
    Join Date
    May 2009
    Posts
    4
    If it was an invalid setting, it wouldn't accept it when I'm connected, right?
    In this moment it is 27dBm, so why I couldn't set it so before I'm connected?

  4. #4
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,397
    Quote Originally Posted by Drycola View Post
    If it was an invalid setting, it wouldn't accept it when I'm connected, right?
    In this moment it is 27dBm, so why I couldn't set it so before I'm connected?
    You got it to 27dBm on Linux? As to why you can't set it before connecting is a question to which I have no answer without some detailed engineering docs for the device itself. Sorry...
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •