Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 17 of 17
Assuming that the problem's source is the laptop, have you tried disabling ipv6? In a root shell enter the following: Code: sysctl -w net.ipv6.conf.all.disable_ipv6=1 sysctl -w net.ipv6.conf.default.disable_ipv6=1 Then restart your ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    Oct 2012
    Posts
    26

    Assuming that the problem's source is the laptop, have you tried disabling ipv6? In a root shell enter the following:

    Code:
    sysctl -w net.ipv6.conf.all.disable_ipv6=1
    sysctl -w net.ipv6.conf.default.disable_ipv6=1
    Then restart your network service:

    Code:
    service network restart

  2. #12
    Just Joined!
    Join Date
    Apr 2013
    Posts
    9
    Yes, it works in Windows. My system is a dual boot system and wireless works absolutely fine. I can connect to router using other devices and they all work fine. As I've mentioned earlier, it always says "Connected", even it gets IP assigned from router (you can check screen-shot in my previous posts) but the only thing is, internet never works, I cannot access router neither can ping it.

    Let me tell you one interesting fact, last night I re-installed RHEL 6. As a matter of fact it worked for 5-10 min and then back to square one (no internet) and i'm struggling again.

  3. #13
    Just Joined!
    Join Date
    Apr 2013
    Posts
    9
    Hi,

    This also didn't work, internet still not worlking. I did as you suggested.

  4. #14
    Just Joined!
    Join Date
    Oct 2012
    Posts
    26
    Wow that's really frustrating. My last guess would be that the wlagn driver that ships with rhel 6 is not the most up to date. Try downloading the ucode:

    • Download "iwlwifi-5000-ucode-5.4.A.11.tar.gz" from "http://intellinuxwireless.org/?n=Downloads".
    • Unzip it to a folder, and copy the "iwlwifi-5000-1.ucode" file to "/lib/firmware"
    • Reboot the machine

  5. #15
    Just Joined!
    Join Date
    Apr 2013
    Posts
    9
    This also didn't work This file is already present in /lib/firmware. I think we'll have to close this chapter unresolved :'(

  6. #16
    Just Joined!
    Join Date
    Apr 2013
    Posts
    9
    Hi,

    Just to keep everyone posted here.. I've upgraded from RHEL 6 to RHEL 6.1 and Wifi is working absolutely fine now. I'm able to connect to internet, can ping the router. The change that I've noticed is, there is a "ifcfg-Auto_belkin.7ad7" (Auto_belkin.7ad7 is the name of my Wifi connection) file in /etc/sysconfig/network-scripts, which i never saw in RHEL 6 when I was struggling to make WIfi work.

  7. #17
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Glad you got it working. Feel free to mark this thread as solved from the thread tools at the top of this page.
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •