Find the answer to your Linux question:
Results 1 to 4 of 4
Problem: I have a USB 3G modem. Which is ZTE MF190. When I plug this modem Code: lsusb gives vendor ID: 19d2 and product ID: 0154. And in this case ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2013
    Posts
    9

    Modem switching problem in USB 3G Modem.


    Problem:
    I have a USB 3G modem. Which is ZTE MF190. When I plug this modem
    Code:
    lsusb
    gives vendor ID: 19d2 and product ID: 0154. And in this case I get no internet access. But when I plug and unplug modem for 3 to 4 times product ID changed to 2003 and then I get internet access. Sometimes I have to plug and unplug modem for 5 to 6 times or even restart. Yes! if I boot my PC with modem plugged it gets product ID 2003 automatically. Now how can I solve this problem so that when I plug the modem and product ID change automatically without unplugging again.

    What I Have Done Already:
    I have tried to understand this manual (draisberghof.de/usb_modeswitch). Actually didn't understand fully.
    I have usb_modeswitch in my PC version 1.2.3.
    I have found a configuration package in /usr/share/usb_modeswitch and in that configuration i have found a text file( paste.ubuntu.com/5944932/ ) named 19d2:0154. In that file target product ID is set to 0117 I have changed It to 2003. But it didn't work. I enabled log for usb_modeswitch. When modem switch successfully( after plugging and unplugging 3 or 4 times ) it gives this log (paste.ubuntu.com/5944950/) . But when fails(most of the times) it gives this log -(paste.ubuntu.com/5944953/)
    I have also tried
    Code:
    usb_modeswitch -v 0x19d2 -p 0x0154 -V 0x19d2 -P 0x2003 -s 20 -M
    But I can't understand how I can get message counter.

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, or in a galaxy far, far away.
    Posts
    11,159
    What distribution+version+kernel are you running? It sounds like the auto-mounter is not letting the device settle after plugging in before it interrogates it for ID information. Currently, my suggestion would be to simply plug it in, and reboot the system since that seems to work - much quicker than waiting for a kernel bug fix...
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  3. #3
    Just Joined!
    Join Date
    Jun 2013
    Posts
    9
    Distro: Ubuntu 12.10
    Kernel: 3.5.0-36-generic

    No other way?

    One solution seems working.
    Code:
    $sudo modprobe -r usbserial
    Code:
    $sudo modprobe usbserial vendor=0x19d2 product=0x0154
    But its not automatic I mean I have to enter this each time before I plug in my modem.

  4. #4
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, or in a galaxy far, far away.
    Posts
    11,159
    A PITA, I agree, but if it works...
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •