Find the answer to your Linux question:
Results 1 to 3 of 3
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie blnl's Avatar
    Join Date
    Jan 2009
    Location
    The Netherlands
    Posts
    207

    15=4WAY_HANDSHAKE_TIMEOUT is killing me


    Since upgrading fc21 to fc22 I'm being plagued by 15=4WAY_HANDSHAKE_TIMEOUT.

    There are no issues with other wireless networks, only one TLS network connection is problematic. The certificates and password are 100% correct, and it does connect from fc22 Live CD running on the very same machine.

    Here is dmesg output while connecting to TLS from fc22 which is installed on the HDD:
    Code:
    [  732.856189] iwlwifi 0000:02:00.0: RF_KILL bit toggled to enable radio.
    [  732.856353] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled
    [  732.856683] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled
    [  733.054622] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled
    [  733.054955] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled
    [  733.074464] IPv6: ADDRCONF(NETDEV_UP): wlp2s0: link is not ready
    [  733.104798] IPv6: ADDRCONF(NETDEV_UP): wlp2s0: link is not ready
    [  742.489390] wlp2s0: authenticate with b0:aa:77:6d:cd:01
    [  742.492447] wlp2s0: send auth to b0:aa:77:6d:cd:01 (try 1/3)
    [  742.493932] wlp2s0: authenticated
    [  742.494054] wlp2s0: associate with b0:aa:77:6d:cd:01 (try 1/3)
    [  742.496846] wlp2s0: RX AssocResp from b0:aa:77:6d:cd:01 (capab=0x111 status=0 aid=16)
    [  742.498413] wlp2s0: associated
    [  742.498441] IPv6: ADDRCONF(NETDEV_CHANGE): wlp2s0: link becomes ready
    [  747.650386] wlp2s0: deauthenticated from b0:aa:77:6d:cd:01 (Reason: 15=4WAY_HANDSHAKE_TIMEOUT)
    [  747.672397] cfg80211: World regulatory domain updated:
    [  747.672404] cfg80211:  DFS Master region: unset
    [  747.672407] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
    [  747.672412] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
    [  747.672417] cfg80211:   (2457000 KHz - 2482000 KHz @ 20000 KHz, 92000 KHz AUTO), (N/A, 2000 mBm), (N/A)
    [  747.672420] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (N/A, 2000 mBm), (N/A)
    [  747.672424] cfg80211:   (5170000 KHz - 5250000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (N/A)
    [  747.672428] cfg80211:   (5250000 KHz - 5330000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (0 s)
    [  747.672431] cfg80211:   (5490000 KHz - 5730000 KHz @ 160000 KHz), (N/A, 2000 mBm), (0 s)
    [  747.672434] cfg80211:   (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
    [  747.672437] cfg80211:   (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 0 mBm), (N/A)
    [  747.678115] cfg80211: Regulatory domain changed to country: NL
    [  747.678121] cfg80211:  DFS Master region: ETSI
    [  747.678124] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
    [  747.678128] cfg80211:   (2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
    [  747.678132] cfg80211:   (5170000 KHz - 5250000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (N/A)
    [  747.678135] cfg80211:   (5250000 KHz - 5330000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (0 s)
    [  747.678138] cfg80211:   (5490000 KHz - 5710000 KHz @ 160000 KHz), (N/A, 2700 mBm), (0 s)
    [  747.678141] cfg80211:   (57000000 KHz - 66000000 KHz @ 2160000 KHz), (N/A, 4000 mBm), (N/A)
    [  747.881704] wlp2s0: authenticate with b0:aa:77:6d:d4:81
    [  747.885051] wlp2s0: send auth to b0:aa:77:6d:d4:81 (try 1/3)
    [  747.885544] wlp2s0: authenticated
    [  747.886017] wlp2s0: associate with b0:aa:77:6d:d4:81 (try 1/3)
    [  747.887812] wlp2s0: RX AssocResp from b0:aa:77:6d:d4:81 (capab=0x111 status=0 aid=6)
    [  747.889559] wlp2s0: associated
    [  753.029293] wlp2s0: deauthenticated from b0:aa:77:6d:d4:81 (Reason: 15=4WAY_HANDSHAKE_TIMEOUT)
    [  753.055458] cfg80211: World regulatory domain updated:
    [  753.055465] cfg80211:  DFS Master region: unset
    [  753.055467] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
    [  753.055472] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
    [  753.055476] cfg80211:   (2457000 KHz - 2482000 KHz @ 20000 KHz, 92000 KHz AUTO), (N/A, 2000 mBm), (N/A)
    [  753.055479] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (N/A, 2000 mBm), (N/A)
    [  753.055483] cfg80211:   (5170000 KHz - 5250000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (N/A)
    [  753.055487] cfg80211:   (5250000 KHz - 5330000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (0 s)
    [  753.055490] cfg80211:   (5490000 KHz - 5730000 KHz @ 160000 KHz), (N/A, 2000 mBm), (0 s)
    [  753.055492] cfg80211:   (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
    [  753.055495] cfg80211:   (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 0 mBm), (N/A)
    [  753.059427] cfg80211: Regulatory domain changed to country: NL
    [  753.059432] cfg80211:  DFS Master region: ETSI
    [  753.059434] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
    [  753.059438] cfg80211:   (2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
    [  753.059441] cfg80211:   (5170000 KHz - 5250000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (N/A)
    [  753.059444] cfg80211:   (5250000 KHz - 5330000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (0 s)
    [  753.059446] cfg80211:   (5490000 KHz - 5710000 KHz @ 160000 KHz), (N/A, 2700 mBm), (0 s)
    [  753.059448] cfg80211:   (57000000 KHz - 66000000 KHz @ 2160000 KHz), (N/A, 4000 mBm), (N/A)
    [  753.250870] wlp2s0: authenticate with b0:aa:77:76:d8:d1
    [  753.256269] wlp2s0: send auth to b0:aa:77:76:d8:d1 (try 1/3)
    [  753.258217] wlp2s0: authenticated
    [  753.258987] wlp2s0: associate with b0:aa:77:76:d8:d1 (try 1/3)
    [  753.261042] wlp2s0: RX AssocResp from b0:aa:77:76:d8:d1 (capab=0x111 status=0 aid=3)
    [  753.262838] wlp2s0: associated
    [  768.011149] wlp2s0: deauthenticating from b0:aa:77:76:d8:d1 by local choice (Reason: 3=DEAUTH_LEAVING)
    [  768.025032] cfg80211: World regulatory domain updated:
    [  768.025040] cfg80211:  DFS Master region: unset
    [  768.025042] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
    [  768.025048] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
    [  768.025053] cfg80211:   (2457000 KHz - 2482000 KHz @ 20000 KHz, 92000 KHz AUTO), (N/A, 2000 mBm), (N/A)
    [  768.025056] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (N/A, 2000 mBm), (N/A)
    [  768.025060] cfg80211:   (5170000 KHz - 5250000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (N/A)
    [  768.025064] cfg80211:   (5250000 KHz - 5330000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (0 s)
    [  768.025068] cfg80211:   (5490000 KHz - 5730000 KHz @ 160000 KHz), (N/A, 2000 mBm), (0 s)
    [  768.025071] cfg80211:   (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
    [  768.025074] cfg80211:   (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 0 mBm), (N/A)
    [  768.032892] cfg80211: Regulatory domain changed to country: NL
    [  768.032901] cfg80211:  DFS Master region: ETSI
    [  768.032905] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
    [  768.032912] cfg80211:   (2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
    [  768.032919] cfg80211:   (5170000 KHz - 5250000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (N/A)
    [  768.032925] cfg80211:   (5250000 KHz - 5330000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (0 s)
    [  768.032931] cfg80211:   (5490000 KHz - 5710000 KHz @ 160000 KHz), (N/A, 2700 mBm), (0 s)
    [  768.032936] cfg80211:   (57000000 KHz - 66000000 KHz @ 2160000 KHz), (N/A, 4000 mBm), (N/A)
    [  773.132219] wlp2s0: authenticate with b0:aa:77:76:d8:d1
    [  773.136927] wlp2s0: send auth to b0:aa:77:76:d8:d1 (try 1/3)
    [  773.273203] wlp2s0: send auth to b0:aa:77:76:d8:d1 (try 2/3)
    [  773.314129] wlp2s0: send auth to b0:aa:77:76:d8:d1 (try 3/3)
    [  773.353018] wlp2s0: authenticated
    [  773.353862] wlp2s0: associate with b0:aa:77:76:d8:d1 (try 1/3)
    [  773.409057] wlp2s0: RX AssocResp from b0:aa:77:76:d8:d1 (capab=0x111 status=0 aid=3)
    [  773.419678] wlp2s0: associated
    Here is dmesg output while connecting to the same TLS from fc22 Live CD:
    Code:
    [ 2497.101333] iwlwifi 0000:02:00.0: RF_KILL bit toggled to enable radio.
    [ 2497.102158] iwlwifi 0000:02:00.0: L1 Disabled - LTR Enabled
    [ 2497.102311] iwlwifi 0000:02:00.0: L1 Disabled - LTR Enabled
    [ 2497.115468] IPv6: ADDRCONF(NETDEV_UP): wlp2s0: link is not ready
    [ 2497.128650] IPv6: ADDRCONF(NETDEV_UP): wlp2s0: link is not ready
    [ 2500.345725] wlp2s0: authenticate with b0:aa:77:6d:cd:01
    [ 2500.347991] wlp2s0: send auth to b0:aa:77:6d:cd:01 (try 1/3)
    [ 2500.349324] wlp2s0: authenticated
    [ 2500.349957] wlp2s0: associate with b0:aa:77:6d:cd:01 (try 1/3)
    [ 2500.354020] wlp2s0: RX AssocResp from b0:aa:77:6d:cd:01 (capab=0x111 status=0 aid=11)
    [ 2500.355497] wlp2s0: associated
    [ 2500.355522] IPv6: ADDRCONF(NETDEV_CHANGE): wlp2s0: link becomes ready
    I have three options here:
    1. downgrade to fc21 (but then I'm forever stuck with fc21, I would like to move forward)
    2. fix the issue with fc22 (but I do not know how)
    3. upgrade to fc23 (since this TLS network does not connect from fc23 Live CD, upgrading to fc23 is not an improvement)


    Can someone please help with this issue?
    Fedora27.GNOME@Dell_Latitude_E7440
    Fedora26.MATE@HP_Compaq_DC7100

  2. #2
    Linux Engineer
    Join Date
    Apr 2012
    Location
    Virginia, USA
    Posts
    1,005
    Google search revealed this bug: https://bugzilla.kernel.org/show_bug.cgi?id=100621

    Possible fix in comment #22.

  3. #3
    Linux Newbie blnl's Avatar
    Join Date
    Jan 2009
    Location
    The Netherlands
    Posts
    207
    -->
    Quote Originally Posted by mizzle View Post
    Google search revealed this bug: https://bugzilla.kernel.org/show_bug.cgi?id=100621

    Possible fix in comment #22.
    That will not work for me, this network does not have WPA-PSK authebtication.
    I do not know how to write a script that includes USER CERTIFICATE, CA CERTIFICATE and PRIVATE KEY.
    Fedora27.GNOME@Dell_Latitude_E7440
    Fedora26.MATE@HP_Compaq_DC7100

$spacer_open
$spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •