Find the answer to your Linux question:
Results 1 to 9 of 9
OK - let me preface this by saying I'm a complete Linux newbie. I come from the dark side (I'm a Microsoft .NET programmer). I have installed FC6 with no ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2006
    Posts
    8

    Cool Operation FC6 madwifi


    OK - let me preface this by saying I'm a complete Linux newbie. I come from the dark side (I'm a Microsoft .NET programmer).

    I have installed FC6 with no issues. However, I have a D-Link DWL-G510 (Atheros-based) wireless NIC that I need to get working. I can't get online at all at this point, as I don't have a 100-foot ethernet cable.

    It seems that madwifi is the way to go for Atheros-based cards. So, I've downloaded the three RPMs I *think* I need from here:

    • madwifi-0.9.3-29_r1754.fc6.at.i386.rpm
    • madwifi-hal-kmdl-2.6.18-1.2798.fc6-0.9.3-29_r1754.fc6.at.i686.rpm
    • madwifi-kmdl-2.6.18-1.2798.fc6-0.9.3-29_r1754.fc6.at.i686.rpm


    I can't install any of them from the command line (e.g. rpm -ivh <filename>), as they all seem to depend on one another.

    How does one go about installing madwifi in FC6? Keep in mind that the box cannot get to the internet, and yum doesn't seem to like not being able to access its repositories.

    Thanks very much, in advance, for any help you can give me.

  2. #2
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    rpm -Uhv madwifi-0.9.3-29_r1754.fc6.at.i386.rpm madwifi-hal-kmdl-2.6.18-1.2798.fc6-0.9.3-29_r1754.fc6.at.i686.rpm madwifi-kmdl-2.6.18-1.2798.fc6-0.9.3-29_r1754.fc6.at.i686.rpm
    all on one line.
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  3. #3
    Just Joined!
    Join Date
    Oct 2006
    Posts
    8
    Thank you! I knew it had to be *something* like that. I'll give it a shot.

    Edit - that worked great - thank you.

  4. #4
    Just Joined!
    Join Date
    Oct 2006
    Posts
    8
    OK - madwifi is installed, and obviously something is working. Executing iwconfig spits this out:

    Code:
    ath0      IEEE 802.11g  ESSID:"piggles"  Nickname:"mulder.fourdixons.com"
              Mode:Monitor  Frequency:2.422 GHz  Access Point: 00:11:95:BE:78:AA   
              Bit Rate:0 kb/s   Tx-Power:18 dBm   Sensitivity=0/3  
              Retry:off   RTS thr:off   Fragment thr:off
              Encryption key:<removed for post>   Security mode:restricted
              Power Management:off
              Link Quality=0/94  Signal level=-90 dBm  Noise level=-90 dBm
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0
    But, dhclient just hangs and won't get me an IP. I get this error message when I attempt to activate the device in system-config-network:

    Error for wireless request "Set Mode" (8B06):
    SET failed on device ath0 ; Invalid Argument.

    Any ideas would be greatly appreciated. Thanks!

  5. #5
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Have you set the mode? Mine is managed mode.
    After you have all your wireless settings in system-config-network, try this as root from a command line.
    service network restart
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  6. #6
    Just Joined!
    Join Date
    Oct 2006
    Posts
    8
    Have you set the mode? Mine is managed mode.
    After you have all your wireless settings in system-config-network, try this as root from a command line.
    service network restart
    My mode is set to Managed as well, but I still get the same error when I restart the network services:

    Error for wireless request "Set Mode" (8B06):
    SET failed on device ath0 ; Invalid Argument.

    I'm going to try turning off encryption to see if that's an issue...

  7. #7
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    post the output of:
    dmesg | grep ath0
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  8. #8
    Just Joined!
    Join Date
    Oct 2006
    Posts
    8
    Wow, wow, wow - somebody kill me.

    The MAC address filter on the access point will most definitely stop me from getting an IP address, won't it?

    <banging head against desk>

    Thanks for your help, MikeTbob - your patience is much appreciated, especially in light of my stupidity.

    This is officially my first post from my new Linux machine.

  9. #9
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Cool Beans, I'm glad you got it working.
    And don't worry. we all have our shining moments of glory otherwise known as stupidus maximus!
    Enjoy
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •