Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
I am a newbie to linux. I just got Suse 10.1 to dual boot with XP on my Compaq v2205us laptop. I love suse and I'm really excited to learn ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2006
    Posts
    7

    Cool Ndiswrapper, SuSE and a Newbie - Help!


    I am a newbie to linux. I just got Suse 10.1 to dual boot with XP on my Compaq v2205us laptop. I love suse and I'm really excited to learn what linux is about. So I guess my wlan device BCM4306 is not supported natively in Suse 10.1. So I am trying to install and configure ndiswrapper.

    First question: Where can I get the windows driver? My first thought is to get it off my windows install. Does anyone know where the drivers are kept?

    I have installed ndiswrapper from the distro cd. I then tried the following command in terminal (home directory I think):

    ndiswrapper

    result (command not found)

    So I thought maybe I need to be in the directory where ndiswrapper was installed. So I searched for files or folders called ndiswrapper. I found the following three directories:

    /etc/ndiswrapper/ empty folder

    /usr/sbin/ perl program

    /usr/share/doc/packages/ndiswrapper/ folder containing readme files.

    So it tried a few commands in each of those directories

    ndiswrapper

    (command not found) same result as before

    So I am totally lost. Do I need to be logged in as root? How do I do that in the terminal anyway?

    Thanks for your help in advance. I really appreciate it.

  2. #2
    kbk
    kbk is offline
    Linux User kbk's Avatar
    Join Date
    Jun 2005
    Location
    Ohio, USA
    Posts
    361
    You do need to be root, and you type "su" in the terminal to do that. As for finding your Windows drivers, that depends on what kind of card you have. If you have a Linksys card you will need to download the drivers from the site (or you can try and use the ones on the disk that came with your card) and then put them on a floppy or cd or something. You will need to do that in Windows since the drivers are in exe format. Another thing, maybe ndiswrapper is installed incorrectly? When I type ndiswrapper in a terminal even as a regular user it comes up with:
    Code:
    kbk@1[~]$ ndiswrapper
    Usage: ndiswrapper OPTION
    
    Manage ndis drivers for ndiswrapper.
    -i inffile        Install driver described by 'inffile'
    -d devid driver   Use installed 'driver' for 'devid'
    -e driver         Remove 'driver'
    -l                List installed drivers
    -m                Write configuration for modprobe
    
    
    where 'devid' is either PCIID or USBID of the form XXXX:XXXX
    . So maybe try re-installing it through your package manager, it should be on one of the installation cds for SuSE.. For a newbie I think this is one of the hardest things to try and do, I've been there many times before (with KNOPPIX, SuSE, Gentoo, Debian Sarge, etc).. Hope this helps.

  3. #3
    Just Joined!
    Join Date
    Oct 2006
    Posts
    7

    Cool Making Progress

    Thanks for your help. It turns out that I needed to log in as root to use almost every command. So I located the driver, installed ndiswrapper, and configured it. I did my best to configure my card to work with my network but I am having trouble connecting.

    I have an open wireless network but use mac address filters to secure it. My mac address is already working because I use the card already on the windows side of my laptop. I set it to dynamic ip, no zone, no network name so I can connect to other networks, no authentication.

    I can see the network in the network manager but the process fails when the network manager tries to configure the card.

    Any ideas????? Let me know if you have additional questions.

  4. #4
    kbk
    kbk is offline
    Linux User kbk's Avatar
    Join Date
    Jun 2005
    Location
    Ohio, USA
    Posts
    361
    Well since I've never used any MAC filtering or anything on my network, I don't think I can help ya with that one.. Sorry..

  5. #5
    Just Joined!
    Join Date
    Oct 2006
    Posts
    7

    Cool Mac Filtering

    The mac filtering shouldn't make a difference on the laptop side. It happens on the wireless router's side. I just has to find the mac address of the wireless card in a table and it will allow access. So it should just configure for open access.

  6. #6
    Just Joined!
    Join Date
    Jan 2006
    Posts
    1
    I've been trying to configure wireless cards on both a laptop and a PC in the last few days. I have successfully installed ndiswrapper, and on the laptop I used iwconfig to configure the settings. It turns out that I was able to connect to the wireless network as long as it was an unsecured network. As soon as I enabled the WEP key, I could not connect. Unfortunately, with the desktop I can not control the access point, so I could not disable the security and therefore don't know if anything is working.

    Anyhow, I don't know if this helps you or not since it sounds like you are not using any sort of passkey. Perhaps you could try turning off all security and the MAC address, and see if that works. By the way, I think you need to do
    Code:
    rehash
    to update the table of commands after you install ndiswrapper. When you open a new shell, or switch to the root user, I think it does this automatically.

  7. #7
    Just Joined!
    Join Date
    Feb 2005
    Location
    between a cup of tea and a cup of no tea
    Posts
    16
    I don't know which desktop either of you are using, but if you can, launch KNetworkManager. It is a system tray icon applet that allows you to select wired or wireless networks on the fly and select how to attach to the wireless networks.

    If your WiFi network has WEP or WPA, then you may need to change the password type.



    You can use WEP passphrase, which is akin to plain text, WEP 40-bit/64-bit/128-bit hex/ASCII or WPA.

    You just select the type in the drop down.

    You can then save the password in KWallet. I use this for connecting at home (40bit WEP) and work (128-bit WPA).

  8. #8
    Just Joined!
    Join Date
    Oct 2006
    Posts
    7

    Talking Got it Working!!!

    I got it working!!! I used Yast to configure the card and then after restarting the system I just needed to modprobe ndiswrapper. The mac filtering didn't need any special configuration on my end. I just configured it as an open access point.

    The configuration tool in Yast worked very well and was pretty easy to use because of the descriptions on the left panel of the tool.

    Thanks for all your help.

  9. #9
    Just Joined!
    Join Date
    Nov 2006
    Location
    Yateley, Hants, UK
    Posts
    3

    Close but no cigar...

    Dear all,

    I am a complete newbie to Linux but loving it (although having a hard time at times). Anyway I have installed SLED 10 and installed ndiswrapper and like EngineeringNerd got a message saying no command found until I changed to root (I have figured out to do that!) and then it worked. I am trying to get my Belkin F5D7011 card to work and copied the driver files bcmwl5a.inf bcmwl5.inf bcmwl5.sys to a directory and then ran the command ndiswrapper -i /link/to/bcmwl5.inf. Unfortunately I received an error message saying "couldn't copy /link/to/bcmwl5.inf at /usr/sbin/ndiswrapper line 135." I installed the driver using ndiswrapper -e bcmwl5 and believe I am now back where I started.

    Any help would be much appreciated.

    Regards,

    Alan

  10. #10
    Linux User Oxygen's Avatar
    Join Date
    Jul 2004
    Location
    Hartlepool, England
    Posts
    392
    Make absolutely sure you have the correct filename, I suggest copying and pasting it into the terminal window if you have to so you can be sure. I got that message when I thought the I was a 1 or the 1 wasan I, I don't fully remember but I got that problem.
    Graham - You'd better Use Linux!

    I'm registerd Linux user #397030. What about you?

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •