Find the answer to your Linux question:
Results 1 to 6 of 6
I have got the wifi card to work without wpa_supplicant but when I try to get the wpa to work it can't connect. Heres some info that may be usefull: ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2006
    Posts
    4

    Can't get WPA to work


    I have got the wifi card to work without wpa_supplicant but when I try to get the wpa to work it can't connect. Heres some info that may be usefull:

    Linux distro: Debian Sarge
    Kernel: 2.6.8
    Wifi Card: Netgear WG511v2 (its the Marvell Chip one)
    Security: TKIP

    iwconfig:
    Code:
    wlan0     IEEE 802.11FH  ESSID:off/any
              Mode:Managed  Channel:0  Access Point: 00:00:00:00:00:00
              Bit Rate:1 Mb/s   Sensitivity=-200 dBm
              RTS thr:2346 B   Fragment thr:2346 B
              Encryption key:off
              Power Management:off
              Link Quality:100/100  Signal level:-46 dBm  Noise level:-256 dBm
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:1  Invalid misc:0   Missed beacon:0
    wpa_supplicant.conf
    Code:
    ctrl_interface=/var/run/wpa_supplicant
    ctrl_interface_group=0
    CONFIG_DRIVER_NDISWRAPPER=y
    CONFIG_CTL_IFACE=y
    
    eapol_version=1
    ap_scan=1
    fast_reauth=1
    
    # Home Wifi Network
    network={
    	ssid="linksys"
    	key_mgmt=WPA-PSK
    	psk="password"
    	pairwise=TKIP
    	proto=WPA
    	group=TKIP
    }
    wpa_supplicant -i wlan0 -c /etc/wpa_supplicant.conf -D ndiswrapper -d
    Code:
    Initializing interface 'wlan0' conf '/etc/wpa_supplicant.conf' driver 'ndiswrapper'
    Configuration file '/etc/wpa_supplicant.conf' -> '/etc/wpa_supplicant.conf'
    Reading configuration file '/etc/wpa_supplicant.conf'
    ctrl_interface='/var/run/wpa_supplicant'
    ctrl_interface_group=0
    Line 3: Invalid configuration line 'CONFIG_DRIVER_NDISWRAPPER=y'.
    Line 4: Invalid configuration line 'CONFIG_CTL_IFACE=y'.
    eapol_version=1
    ap_scan=1
    fast_reauth=1
    Priority group 0
       id=0 ssid='linksys'
    Failed to read configuration file '/etc/wpa_supplicant.conf'.
    Any help will be very usefull. I have tried various things primary with the wpa_supplicant.conf file with no luck. Like I said everything works except for the wpa security which the card does supports according to the specs on the box and on the Netgear site.

  2. #2
    Just Joined!
    Join Date
    Feb 2005
    Location
    between a cup of tea and a cup of no tea
    Posts
    16
    Couple of things:

    First, can you turn off your security in your router and connect?

    If so, then you want to check what your passphrase is set at in your router.

  3. #3
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    The wpasupplicant version that comes with Debian Sarge is quite old (0.3.8-1). I wasn't able to do anything with it either.

    I suggest you either upgrade to Debian Etch (with which you'll find your laptop to be much more functionnal anyway) or you use Debian Sarge's backports to fetch a newer version of wpasupplicant (if one is available there).
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Nov 2006
    Posts
    4
    Quote Originally Posted by Perfect Reign
    Couple of things:

    First, can you turn off your security in your router and connect?

    If so, then you want to check what your passphrase is set at in your router.
    I can connect with the security off. The passphrase is correct, I just used a different one here for security reasons.

    Quote Originally Posted by antidrugue
    The wpasupplicant version that comes with Debian Sarge is quite old (0.3.8-1). I wasn't able to do anything with it either.

    I suggest you either upgrade to Debian Etch (with which you'll find your laptop to be much more functionnal anyway) or you use Debian Sarge's backports to fetch a newer version of wpasupplicant (if one is available there).
    Isn't Etch coming out in December? If so it be bearly a month wait really assuming things go smoothly. But since it seems most of the bugs are worked out in Etch I will download it and install it. Hopefully that will fix my problem. I was going to look into compiling the Network Manager for Gnome, because from what I have read it manages wifi connections and you can define the passpharses better in it.

    And getting more functionality out of a 5 year old laptop (it came out in 2001) is always a good thing, especially when one of its uses is for car dynostics.

    But I thank you both for helping anyway, and I am off downloading Etch.

  6. #5
    Just Joined!
    Join Date
    Nov 2006
    Posts
    4
    Ya it works now. It even sees the wifi card completely when I do lspci after I installed ndiswrapper.

  7. #6
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    Plus, NetworkManager is available for Etch. So all is good.
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •