Find the answer to your Linux question:
Results 1 to 6 of 6
I am trying to get my built in wireless to work in FC6 its a intel Pro/wireless 2200bg I have the driver. but I cannot get it to connect...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! bobkat357's Avatar
    Join Date
    Apr 2005
    Location
    Dallas TX
    Posts
    76

    wireless help, Fedora


    I am trying to get my built in wireless to work in FC6 its a intel Pro/wireless 2200bg I have the driver. but I cannot get it to connect

  2. #2
    Just Joined! cuervo73's Avatar
    Join Date
    Apr 2006
    Posts
    47

    Re: wireless help, Fedora

    BK,

    same answer as I gave as GODDLY.. go get <ndiswrapper> and <wpa_supplicant> and install them. Find them by Google search. You can use the Windows driver provided by the vendor under Linux.

    cuervo

  3. #3
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    Quote Originally Posted by cuervo73
    same answer as I gave as GODDLY.. go get <ndiswrapper>
    Why use NDISWRAPPER when there is a perfectly working official Linux driver for the IPW2200 ?

    http://ipw2200.sourceforge.net/
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined! cuervo73's Avatar
    Join Date
    Apr 2006
    Posts
    47

    Re: wireless help, Fedora

    Oh, OK.. sounds reasonable

    what have you tried and what were the results/errors? more info about what you did..
    "..have the driver but can't get it to connect"

    1. does the driver even load ? does it show something about that wireless device in /var/log/messages file during bootup?

    2. what does lsmod show? is the driver shown as loaded there?

    3. if not, can you force the driver to load with: modprobe DRIVERNAME or insmod DRIVERNAME? (substitute your actual driver name for DRIVERNAME, of course)

    4. try this sequence:

    iwlist wlan0 scan
    ( does it see any access point?)
    (if so, extract the essid and chan # and place into...)

    iwconfig essid "YOUR-ESSID" channel YOUR-CHANNEL

    ifconfig wlan0 up

    dhclient wlan0

    (now, go look at the lease file to find the gateway IP address)

    cat /var/lib/dhcp/dhclient.leases

    (the line that says option routers xx.xx.xx.xx)

    route add default gw xx.xx.xx.xx

    netstat -rn

    (does the link LED light up on the wireless NIC??)


    cuervo

  6. #5
    Just Joined! cuervo73's Avatar
    Join Date
    Apr 2006
    Posts
    47

    Re: wireless help, Fedora

    one more thing... I used a device name of "wlan0" in my commend seuence above.. your device may not be "wlan0".. check the /var/log/messages file for the correct device name and substitute that for wherever you see my use of "wlan0" in prior posting.

    cuervo

  7. #6
    Just Joined! bobkat357's Avatar
    Join Date
    Apr 2005
    Location
    Dallas TX
    Posts
    76
    cool thanks I have to wait tell wed to finish getting it ready when I get back to Dallas

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •