Hello, i try to install the ieee802 package but i have a problem when i try to make it


Checking in /lib/modules/2.6.18-1.2849.fc6xen for ieee80211 components...
find: /lib/modules/2.6.18-1.2849.fc6xen/build/: No such file or directory
/lib/modules/2.6.18-1.2849.fc6xen/updates/net/ieee80211/ieee80211_crypt_tkip.ko
/lib/modules/2.6.18-1.2849.fc6xen/updates/net/ieee80211/ieee80211_crypt.ko
/lib/modules/2.6.18-1.2849.fc6xen/updates/net/ieee80211/ieee80211.ko
/lib/modules/2.6.18-1.2849.fc6xen/updates/net/ieee80211/.tmp_versions/ieee80211_crypt_ccmp.mod
/lib/modules/2.6.18-1.2849.fc6xen/updates/net/ieee80211/.tmp_versions/ieee80211_crypt_wep.mod
/lib/modules/2.6.18-1.2849.fc6xen/updates/net/ieee80211/.tmp_versions/ieee80211.mod
/lib/modules/2.6.18-1.2849.fc6xen/updates/net/ieee80211/.tmp_versions/ieee80211_crypt_tkip.mod
/lib/modules/2.6.18-1.2849.fc6xen/updates/net/ieee80211/.tmp_versions/ieee80211_crypt.mod
/lib/modules/2.6.18-1.2849.fc6xen/updates/net/ieee80211/ieee80211_crypt_ccmp.ko
/lib/modules/2.6.18-1.2849.fc6xen/updates/net/ieee80211/ieee80211_crypt_wep.ko
Above files found. Remove? [y],n y
find: /lib/modules/2.6.18-1.2849.fc6xen/build/: No such file or directory
rm: cannot remove `/lib/modules/2.6.18-1.2849.fc6xen/updates/net/ieee80211/ieee80211_crypt_tkip.ko': Permission denied
rm: cannot remove `/lib/modules/2.6.18-1.2849.fc6xen/updates/net/ieee80211/ieee80211_crypt.ko': Permission denied
rm: cannot remove `/lib/modules/2.6.18-1.2849.fc6xen/updates/net/ieee80211/ieee80211.ko': Permission denied
rm: cannot remove `/lib/modules/2.6.18-1.2849.fc6xen/updates/net/ieee80211/.tmp_versions/ieee80211_crypt_ccmp.mod': Permission denied
rm: cannot remove `/lib/modules/2.6.18-1.2849.fc6xen/updates/net/ieee80211/.tmp_versions/ieee80211_crypt_wep.mod': Permission denied
rm: cannot remove `/lib/modules/2.6.18-1.2849.fc6xen/updates/net/ieee80211/.tmp_versions/ieee80211.mod': Permission denied
rm: cannot remove `/lib/modules/2.6.18-1.2849.fc6xen/updates/net/ieee80211/.tmp_versions/ieee80211_crypt_tkip.mod': Permission denied
rm: cannot remove `/lib/modules/2.6.18-1.2849.fc6xen/updates/net/ieee80211/.tmp_versions/ieee80211_crypt.mod': Permission denied
rm: cannot remove `/lib/modules/2.6.18-1.2849.fc6xen/updates/net/ieee80211/ieee80211_crypt_ccmp.ko': Permission denied
rm: cannot remove `/lib/modules/2.6.18-1.2849.fc6xen/updates/net/ieee80211/ieee80211_crypt_wep.ko': Permission denied
Old ieee80211 references found. In order to build the ieee80211
subsystem, prior versions must first be removed. You can perform
this task by running this makefile as root via:

% sudo make check_old

and answering Y to remove the file references.
Aborting make.
make: *** [check_old] Error 1



i run a FC6 a my wireless card is a Intel Pro 3945
i already download the 3945 package from intel site.




and when i launch the ipw3945 it sends me the following error

[marcoguillen@localhost ipw3945-1.0.0]$ make

ERROR: ieee80211.h not found in '/lib/modules/2.6.18-1.2849.fc6xen/include'.

You need to install the ieee80211 subsystem from http://ieee80211.sf.net
and point this build to the location where you installed those sources, eg.:

% make IEEE80211_INC=/usr/src/ieee80211/

will look for ieee80211.h in /usr/src/ieee80211/net/

make: *** [check_inc] Error 1
[marcoguillen@localhost ipw3945-1.0.0]$

thanks for your replies