Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 20 of 20
OMG... I tried uninstalling and reinstalling ndiswrapper... I got the 1.31 version and when I tried to make, I got something along the lines of, "welp, you're screwed! you either ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux Newbie
    Join Date
    Jun 2006
    Posts
    150

    Angry


    OMG... I tried uninstalling and reinstalling ndiswrapper... I got the 1.31 version and when I tried to make, I got something along the lines of, "welp, you're screwed! you either get to (omg) reinstall the kernel because of some stupid CONFIG_4KSTACK parameter that the screws with windows drivers, or you can go **** yourself and live without wireless internet..." I guess that explains it... What do I have to do to re-compile a kernel...

  2. #12
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    Your kernel is not borked. It's just that they have been very adamant about fixing the stack size in some kernels before compiling the drivers which is necessary for them to run properly. I've noticed the language has become increasingly more strident as newer versions come out. Can you post the exact message? I'd be interested to see it. I've seen this before and think it is in extremely poor taste to make such "error messages." Free or not, it's totally uncalled for.

    I'll see if I can locate a re-compile how-to for your distro...
    Last edited by Dapper Dan; 12-07-2006 at 11:48 PM.
    Linux Mint + IceWM Registered: #371367 New Members: click here

  3. #13
    Linux Newbie
    Join Date
    Jun 2006
    Posts
    150
    lol, sorry, that was a paraphrase in a moment of extreme anger thinking that I would have to reinstall the kernel, which I have tried before... Didn't end well, even after many attempts... Was NOT looking forward to going through that again... Sorry for the confusion, and the language... Do you still want the error message?

  4. $spacer_open
    $spacer_close
  5. #14
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    Reinstalling the kernel is not that hard, as :
    Code:
    apt-get install linux-image-2.6-686
    will do it.

    Then you must compile the ndiswrapper kernel module :
    Code:
    apt-get install ndiswrapper-source module-assistant
    cd /usr/src
    m-a prepare
    m-a a-i ndiswrapper
    That's it.

    It appears that the kernel you are using right now doesn't have a ndiswrapper module. Are you sure you compiled it ?
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  6. #15
    Linux Newbie
    Join Date
    Jun 2006
    Posts
    150
    If I didn't compile it, then how would it appear as a command? I think that I just apt-g(o)t it. I'm using Debian Etch with an AMD Sempron 32bit if it makes any difference. Will that reset the CONFIG_4KSTACK?

  7. #16
    Linux Newbie
    Join Date
    Jun 2006
    Posts
    150
    O.K! I can see the NDiswrapper driver inside the lsmod. I guess it didn't like just "make" because when I ran "make install" ndiswrapper worked just fine. However, now, thanks to a graphics bug, I had to improperly shut down while I had granted root rights to the terminal... Now I can't seem to open any aplications that need Root permissions. I can still su in through the normal (non-root) terminal, but that means that I cannot start my networking tools... I'm doing a dist-upgrade now over my Wired internet connection in the hopes that it will fix the problem... but I doubt it... Any ideas?

  8. #17
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    How are you running those applications that need root privilages? Are you doing su, then running the app? Do you have KDE installed? Try as regular user:
    Code:
    kdesu application_you_want_to_run
    Not running "make install" seems to have been your trouble all along! If you are now seeing ndiswrapper when running lsmod, you are ready to configure your wireless device. Go back to my previous post and pick up where configuring wlan0 begins.
    Last edited by Dapper Dan; 12-08-2006 at 01:52 AM.
    Linux Mint + IceWM Registered: #371367 New Members: click here

  9. #18
    Linux Newbie
    Join Date
    Jun 2006
    Posts
    150
    O.k. Big problems... I got the WMP54GSa.inf driver loaded with driver present and hardware present (the bcm's didn't work). Ndiswrapper only comes up in lsmod when I boot half the time. Also, KWifimanager and ifup *Eth1* say that it is installed and working. However, KWifi cannot pick up the signal. It shows a small signal (orange and very low), but cannot connect to the network. I think that I already have my /etc/network/interfaces files setup already. The final thing, I don't think that I have dhcpcd... It just doesn't come up (even when root).

  10. #19
    Linux Newbie
    Join Date
    Jun 2006
    Posts
    150
    Oh btw, I have root access to my apps again, I formatted the swap parition and restarted, worked like a charm! Oh, in case your still wondering, I have gnome, and this was a recent development. It happened while I was trying to set up the drivers, but I'm pretty sure that it is unrelated.

  11. #20
    Linux Newbie
    Join Date
    Jun 2006
    Posts
    150
    GREAT NEWS GUYS!!! I've finally got it working. I was booting up my machine and noticed that the BCM43XX driver was still trying to do something at startup. I must not have blacklisted the driver correctly. I got a guide written SPECIFICALLY for my wireless network card. It told me how to blacklist it correctly and how to remove the other driver (which has major issues with this card in particular). I'll try to post a link soon!

    EDIT: http://www.linuxquestions.org/questi...d.php?t=473194

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •