Find the answer to your Linux question:
Results 1 to 6 of 6
Hi, Just installed FC6 on my new machine, and have a wireless card wich should use the rt2500 driver. I have read the threads concerning setup with FC5, but following ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2006
    Posts
    3

    RT2500 and fedora core 6


    Hi,

    Just installed FC6 on my new machine, and have a wireless card wich should use the rt2500 driver. I have read the threads concerning setup with FC5, but following the steps in that howto leads me nowhere. I have used linux for some time, but only installed stuff by follwing howtos on the web.

    I have donwloaded the latest build of rt2500 and installed the kernel-devel rpm package. I seem to have problems including links to various config file. When compiling, I get error-messages like these (only the first lines are included here):

    [root@localhost Module]# make
    cc -D__KERNEL__ -I/usr/src/redhat/BUILD/kernel-2.6.18/linux/include -O2 -fomit-frame-pointer -fno-strict-aliasing -fno-common -pipe -mpreferred-stack-boundary=2 -march=i686 -DMODULE -DMODVERSIONS -include /usr/src/redhat/BUILD/kernel-2.6.18/linux/include/linux/modversions.h -Wall -Wstrict-prototypes -Wno-trigraphs -c -o rtmp_main.o rtmp_main.c
    In file included from rtmp_main.c:38:
    rt_config.h:53:40: error: linux/config.h: No such file or directory
    In file included from /usr/src/redhat/BUILD/kernel-2.6.18/linux/include/asm/thread_info.h:16,
    from /usr/src/redhat/BUILD/kernel-2.6.18/linux/include/linux/thread_info.h:21,
    from /usr/src/redhat/BUILD/kernel-2.6.18/linux/include/linux/preempt.h:9,

    My guess is that the special FC directory tree structure is screwing things up - or I might be missing something important. Please help......

    sol101

  2. #2
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,628
    Hi sun101 and welcome to Linuxforums.
    This should help.
    Linux Mint + IceWM Registered:#371367 New Members: click here

  3. #3
    Just Joined!
    Join Date
    Dec 2006
    Posts
    3

    Got further, but not there yet

    Hi Dapper Dan,

    thsnkd for the very fast reply. Now the compilation got further, but not all the way it seems. It nows makes it past the include statement, but now finds errors in the code files themselves.
    Should maybe mention that my config file looks like this:
    LINUX_SRC=/usr/src/kernels/2.6.18-1.2849.fc6-i686
    TARGET_MODDIR=/lib/modules/

    and that I use
    gcc version 4.1.1 20061011 (Red Hat 4.1.1-30)

    Heres the new error message:

    In file included from /usr/src/redhat/BUILD/kernel-2.6.18/linux/include/linux/rwsem.h:24,
    from /usr/src/redhat/BUILD/kernel-2.6.18/linux/include/asm/semaphore.h:42,
    from /usr/src/redhat/BUILD/kernel-2.6.18/linux/include/linux/sched.h:57,
    from /usr/src/redhat/BUILD/kernel-2.6.18/linux/include/linux/module.h:9,
    from rt_config.h:54,
    from rtmp_main.c:38:
    /usr/src/redhat/BUILD/kernel-2.6.18/linux/include/asm/rwsem.h: In function ‘__down_read’:
    /usr/src/redhat/BUILD/kernel-2.6.18/linux/include/asm/rwsem.h:104: error: expected ‘:’ or ‘)’ before ‘KBUILD_BASENAME’
    /usr/src/redhat/BUILD/kernel-2.6.18/linux/include/asm/rwsem.h: In function ‘__down_write_nested’:
    /usr/src/redhat/BUILD/kernel-2.6.18/linux/include/asm/rwsem.h:156: error: expected ‘:’ or ‘)’ before ‘KBUILD_BASENAME’

    ........


    I'm terribly soory about this debugging I'm asking you guys to do - excuse my ignorence

    sun101

  4. #4
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,628
    I've Googled this thing to death and can come up with nothing. Fedora Core 6 is very bleeding edge and these types of errors are what you run into when living on the outside edge of the Linux envelope. I didn't run into these errors in either CentOS 4.2 or Slackware 10.2 building this same driver. I wish I could help but frankly am out of ideas, other than this is just something that has changed in FC6 like what was the case with your first error. I went through just about every one of these links and could find nothing that was apparently helpful...
    error: expected ‘:’ or ‘)’ before ‘KBUILD_BASENAME’

    Sorry I couldn't help more...
    Linux Mint + IceWM Registered:#371367 New Members: click here

  5. #5
    Just Joined!
    Join Date
    Dec 2006
    Posts
    3

    finally it's working

    Hi,

    Just wanted to post that after even more extensive googling, I got my rt61 chipset card to work. It turns out that rpm's have been made for FC6, and after installing and messing around with the settings, everything works perfect. Found the link in a small post on the serialmonkey mailing list. I inlude the link to the post and the link to the ftp-site where they can be donwloaded. Hope this will help others.

    http://rt2x00.serialmonkey.com/phpBB...35bdee2a1625f1

    ftp://netst.org/pub/linux/ralink/

    Sun101

  6. #6
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,628
    Quote Originally Posted by sun101
    Just wanted to post that after even more extensive googling, I got my rt61 chipset card to work.
    That's great news! Congratulations sun101! It's always good to see a new member who won't give up and perseveres!
    Linux Mint + IceWM Registered:#371367 New Members: click here

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •