Find the answer to your Linux question:
Results 1 to 7 of 7
I am soooo a newbie. This is the 3rd time in 2 years I have tried to switch to Linux as my installed os. I purchased a Belkin f5d7010 wireless ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2006
    Posts
    4

    Unhappy help! madwifi, belkin card, nothing works!


    I am soooo a newbie.

    This is the 3rd time in 2 years I have tried to switch to Linux as my installed os.
    I purchased a Belkin f5d7010 wireless card with Atheros chipset. Tried to get it to work on knoppix live cd with ndiswrapper. I could see networks but couldn't connect to them with netcardconfig.

    I then read that madwifi works for atheros chipsets, so I decided to hd install knoppix and try madwifi because I couldn't figure out how to do it with the live cd.

    I've gone through several forums following the directions for building, installing madwifi and followed the directions, however, nothing goes smoothly. for instance when performing : # make install
    it goes through and after a few lines I see something like:

    cp: cannot stat 'ath_pci.ko" : no such file or directory
    make[1]: *** [install] Error 1
    make[1]: Leaving directory "/root/madwifi-0.9.2.1/ath'

    I'm new, but somehow that seems important. I trudge on however, because I've yet to find a screenshot of what make install is supposed to return so I figure maybe that's what is supposed to happen. If not I don't know how to fix it.

    moving on I perform # modprobe ath_pci
    this returns

    WARNING: /etc/modprobe.d/aliases line 159: ignoring bad line starting with "alia"
    FATAL: Module ath_pci not found

    any help would be great.

    BTW: knoppix 5.0.1
    kernel 2.6.17
    madwifi 9.2.1
    thanks

  2. #2
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    Unless I am mistaking, the Madwifi drivers are installed by default in Knoppix. Are you sure your card is supported by the Madwifi driver ?
    http://madwifi.org/wiki/Compatibility#Belkin

    I understand it is a f5d7010, but which revision is it ?
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  3. #3
    Just Joined!
    Join Date
    Dec 2006
    Posts
    4
    When I perform lspci it returns

    Atheros Communications, Inc,: Unknown device 001a (rev 01)

    Therefore, I am not shure exactly what chipset it has or how to find out

    On the back of the card it says version 5100 and I am unable to find on madwifi or ndiswrapper sites this card with this version number, so maybe I should take it back and try a different brand?
    Any suggestions?

  4. #4
    Just Joined!
    Join Date
    Dec 2006
    Posts
    4
    has anyone had any success with this card? belkin f5d7010 ver. 5100
    Atheros chipset

    I can find this version number with this model on any of the supported devices pages for ndiswrapper or mad wifi. Maybe it's just new? any thoughts, suggestions?

  5. #5
    Just Joined!
    Join Date
    Dec 2006
    Location
    Noida/India
    Posts
    2
    I am also having Atheros's wifi pci adapter (pci id 168c:011a) .
    I am also a newbie to Linux Networking, after lot of googling i found that madwifi work for atheros.
    But now the issue is that how to install and detect the madwifi after installation...?
    I tried with at tar of madwifi. I installed it and when i am trying : -
    [ #] modprobe ath_pci
    it shows nothing, simply prompts to command prompt without any messag.

    how can i detect weather driver (madwifi) is installed properly or not..?

  6. #6
    Just Joined!
    Join Date
    Dec 2006
    Posts
    4
    I don't know that I can solve your problems as I abandoned hope for my card and exchanged it for a linksus card that works with ndiswrapper. If you purchased a new card I might suggest this form of trial and error to you: if you can't get it to work in a short amount of time ( like a day or two ) and you just purchased it, take it back and exchange it for a different model. It took me 5 times exchanging cards, but I had my current card working in less than 5 minutes. If you can't take it back or haven't lost hope yet, all I can offer ( as I too am new to Linux ) is I believe that if you typed: # modprobe ath_pci and nothing happened, that is a good thing. If it didn't work you would have gotten messages informing you of failure. The next step I would perform is # iwconfig
    if you now see a device like ath0 or ath1 then it worked. You should also see some new device by doing ifconfig . . .I think. If you don't you might try # ifconfig ath0 up This is where I had problems though, I could see the card, I could scan for routers ( # iwlist ath0 scanning ) and could see them, but I could never manage to connect to them. I could never get IP addresses. I think there is a command like dhcpcd or something but I couldn't get it to work. Sorry I can't help more, good luck!

  7. #7
    Just Joined! namelessone's Avatar
    Join Date
    May 2006
    Posts
    62
    I tried with at tar of madwifi. I installed it and when i am trying : -
    [ #] modprobe ath_pci
    it shows nothing, simply prompts to command prompt without any messag.
    Linux terminals are very untalkative. Since it didn't say anything it means that you successfully loaded the ath_pci module.

    Your next step is to type iwconfig to see what the name of your device is.

    Then type
    Code:
    iwconfig devicename essid "ESSID"
    replacing "ESSID" with your essid

    And if you are connecting to a network with wep,
    Code:
    iwconfig devicename key (key)
    replacing (key) with the wep key.

    Then just use dhcp to get an ip address
    dhclient devicename
    by the way, your device name will be something like ath0

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •