Find the answer to your Linux question:
Results 1 to 3 of 3
Hello everyone. I hope there is someone who can help me deal with this as I am getting VERY, VERY frustrated here... What I need to do is to get ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    lhm
    lhm is offline
    Just Joined!
    Join Date
    Dec 2006
    Posts
    9

    Ndiswrapper: almost there but what am I doing wrong?


    Hello everyone.

    I hope there is someone who can help me deal with this as I am getting VERY, VERY frustrated here...

    What I need to do is to get my IBM 390X laptop work with Belkin F5D7050 USB wireless network adapter with WPA-PSK (TKIP). I understand, I have to use Ndiswrapper to get the drivers work and then wpa_supplicant to make WPA work. To make it easier, I changed my encryption to WEP for time being in order to be able to see wheather the Ndis-wrapped driver works in the first place before starting to play with wpa_supplicant.

    My machine has Debian Etch (testing 2.6.18-3-686) installed on it which was installed using Cisco Aironet 350 NIC. That one connects to internet no trouble at all. Plugged in the Belkin adapter and ran the following commands as instructed here:

    1. apt-get install module-assistant
    2. module-assistant prepare
    3. apt-get install ndiswrapper-source
    4. module-assistant build ndiswrapper
    5. apt-get install ndiswrapper-utils
    6. module-assistant install ndiswrapper
    7. ndiswrapper -i /file/path/filename.inf
    8. depmod -a
    9. modprobe ndiswrapper

    All that ran no problem at all. Then I ran ndiswrapper -l which returned:

    rt2500usb invalid driver!

    To correct that one (as I found instructed somewhere on the web), I copied rt2500usb.sys to /etc/ndiswrapper/rt2500usb. Running ndiswrapper -l after that returned:

    rt2500usb driver present, hardware (050D:7050) present

    BUT. ifconfig wlan0 up returns:

    wlan0: ERROR while getting interface flags: No such device

    The output of my ifconfig is as follows:

    eth0 Link encap:Ethernet HWaddr [Cisco aironet MAC address here]
    inet6 addr: fe80::20d::28ff::fef4::be9a/64 Scope:Link
    UP BROADCAST MULTICAST and so on...
    lo Link enca;:Local Loopback
    inet addre:127.0.0.1 Mask 255.0.0.0 and so on...

    And the output of my iwconfig is this:

    sit0 no wireless extensions

    eth0 IEEE 802.11-DS ESSID:"My essid"
    Mode:Managed Frequency:2.442 GHz Access Point: [router's mac address here]
    Bit Rate:11 Mb/s and so on...
    wifi0 all the same as for eth0 goes here

    I wondered if that sit0 actually was my USB adapter but after doing ifconfig sit0 up and ifconfig what I got for sit0 was:
    sit0 Link encap:IPv6-in-IPv4
    inet6 addr: ::127.0.0.1/96 Scope:Unknown
    UP RUNNING NOARP MTU:1480 Metric:1
    Rx packets, Tx packets and so on

    Can someone explain what's going on, I have been struggling with this for so long now... please.

  2. #2
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    Don't know if this would matter, but I think you run ndiswrapper -l right after ndiswrapper -i to ensure the driver is properly installed and hardware is present. I've never run it after depmod -a and modprobe. Possibly it could give a different reading depending on when you do it? It seems if you ran modprobe ndiswrapper without complaints, the driver should be installed. I have the same chipset in a Dlink and with ndiswrapper it uses from the included CD netrtusb. I had major problems with it locking my system. As I did, you could try the native rt2570 driver from serialmonkey. I'm using that right now and so far I'm getting good results. I couldn't advise on the business about the .sys file, but maybe thats why it won't see it as a device. I've also found different versions of Ndiswrapper give widely varying results. I'd try a different version of ndiswrapper just to see, and install the .inf file. Also, is the driver you are installing from XP? Have you tried the others? Win2k etc? You've probably considered all of these things. I'd give the rt2570 a try though. Sorry I couldn't help more...
    Last edited by Dapper Dan; 12-22-2006 at 02:37 AM.
    Linux Mint + IceWM Registered: #371367 New Members: click here

  3. #3
    lhm
    lhm is offline
    Just Joined!
    Join Date
    Dec 2006
    Posts
    9
    You are right there, I did run depmod -a and modprobe ndiswrapperbefore ndiswrapper -l but that should be the right thing to do. I will try the rt2570 driver from serialmonkey, as you suggested. With the version of ndiswrapper, I think it downloads the most recent one automatically well, I hope so, because I don't want to have all this business of uninstalling it again, easier just to re-do the whole OS for me. Yes, the driver I was trying to install is from the CD that came with it. But I installed it with Sarge in the past and it worked like a dream. May be Etch would like the serialmonkey driver better? But I'll give rt2570 a try and post the results tonight. thank you for the advice, LHM

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •