Find the answer to your Linux question:
Results 1 to 5 of 5
Hi everybody, I'm running the MiniEdition of Sabayon Linux on an Alienware Aurora m9700. I've installed MadWifi per the online instructions, and everything seemed to be fine and dandy until ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2006
    Location
    Hunterdon County, NJ
    Posts
    17

    Atheros Card Won't Connect! MadWifi Installed!


    Hi everybody,
    I'm running the MiniEdition of Sabayon Linux on an Alienware Aurora m9700. I've installed MadWifi per the online instructions, and everything seemed to be fine and dandy until I tried to connect. When I click on a network (any network) in the dropdown list (using KNetworkManager), the connection progress bar stops at 28%, and it says "Activation Stage: Configuring Device". It just stops there, and eventually gives up. I can connect just fine through my ethernet port (a Marvell device).

    Any advice?

    Thanks,
    Mike

  2. #2
    Just Joined!
    Join Date
    Dec 2006
    Posts
    5
    I get the same type of message. It just waits at the 57% and keeps trying to connect. I have been trying for over 3 weeks. I have even ordered a prism card to see if it works. So far my linux experience I am truely handicapped until I get the wireless going. Of course I could buy a very long Cat cable

    dennis

  3. #3
    Just Joined! namelessone's Avatar
    Join Date
    May 2006
    Posts
    62
    Your main problem is you are using KNetworkManager. It is seriously flawed, and it just doesn't work right.

    You can still get your card up and running, though, but you have to do it from the command line. It might sound scary, but it's not that hard, and in the end it is faster to do it from the terminal than from a gui interface.

    Your first step is to open up a terminal. Next, type

    Code:
    iwconfig
    This will list all wireless interfaces. Your interface should be something like ath0.

    Once you know what interface it is on, type

    Code:
    iwconfig ath0 essid "ESSID"
    replace ath0 with your interface, and replace "ESSID" with your essid (keep the quotes)

    if you have a wep key, type
    Code:
    iwconfig ath0 key yourkeyinhex
    finally, type

    Code:
    dhclient ath0
    to configure your connection with dhcp.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jan 2007
    Posts
    1

    Talking

    I was having the same problem thank you for this info! Can I set this up to run automatically? I would just make a sh script and get it to run on boot or something, but that seems a bit insecure when the network key would have to be inside the script. I guess it's not really a big deal but if theres a better way I'd like to know about it. Also contemplating getting rid of the key... anyways thank you!

  6. #5
    Just Joined! namelessone's Avatar
    Join Date
    May 2006
    Posts
    62
    Can I set this up to run automatically?
    Yes, there is some way to do this...there is some configuration file I think...I'm not sure how to do it, though. I use Ubuntu and it saves all that stuff for me automatically...

    Also contemplating getting rid of the key...
    I'd keep it if I were you. Although it isn't that secure, it will at least slow down people from accessing your network. If at all possible, use wpa instead of wep. It is much harder to crack.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •