Find the answer to your Linux question:
Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 28
Hi guys, I'm a complete newbie with linux so bare with me. I was planning on learning everything on my own and not asking too many questions but I need ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2006
    Posts
    18

    ndiswrapper / wireless suse linux problems


    Hi guys, I'm a complete newbie with linux so bare with me. I was planning on learning everything on my own and not asking too many questions but I need firefox working so I can browse tutorials

    Ok, so my problem is that I cannot get my wireless NIC working. The card is called..
    - Dell BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller DHCP

    I have installed ndiswrapper and I have located the correct drivers for my card through some online lookup list (b44win.inf, bcm4sbxp.sys). When I type in "ndiswrapper -l " I get..
    - b44win driver installed, hardware (14E4:4401) present (alternate driver: b44)

    When I type "iwconfig" I get..
    -
    lo no wireless extensions.

    eth0 no wireless extensions.

    eth1 IEEE 802.11b/q ESSID: off/any Nickname: "laptop-suse"
    Mode: Managed Access Point: Invalid
    RTS thr:off Fragment thr: off
    Encryption key: 3030-3030-3030-etc Security Mode: open
    (rest of the options are 0 ie - link quality, signal level, etc)

    sit0 no wireless extensions.

    Shouldn't I get a wlan0 instead of eth1?? eth0 is my regular NIC.

    Let me know anymore commands I should type for information.

    Thankyou,
    Travis

  2. #2
    Just Joined!
    Join Date
    Dec 2006
    Posts
    18
    Anyone have any ideas? I've retraced through several tutorials now and I don't know what I am doing wrong.

    I unzip the driver, find the .inf and .sys file and place them in /usr/sbin. Then i type ndiswrapper -i b44win.inf and it installs fine. ndiswrapper -l shows that is installed fine. modprobe ndiswrapper shows no errors. iwconfig does not show a wlan0 ;(

  3. #3
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    eth1 is your wireless so whats the problem? I think, it may be using a different driver than ndiswrapper which is no big deal...
    Life is complex, it has a real part and an imaginary part.

  4. #4
    Just Joined!
    Join Date
    Dec 2006
    Posts
    18
    In that case, how do I force it to use the ndiswrapper driver?

  5. #5
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    Quote Originally Posted by evilamigo
    how do I force it to use the ndiswrapper driver?
    try this:
    Code:
    rmmod b44
    modprobe ndiswrapper
    What i don't understand is if the driver is already loaded, why do you want to force it to use ndiswrapper? Is the card not connecting or something?

    Traditionally in Linux network cards are called ethX with X being a number, with the advent of ndiswrapper, it renames the network device to wlanX with wlan0 being the first wireless network card. If a Linux driver for the network card is used, regardless of if it is wired or wireless it is called ethX.

    Also which distro are you running?
    Life is complex, it has a real part and an imaginary part.

  6. #6
    Just Joined! Danny Lawson's Avatar
    Join Date
    Dec 2006
    Posts
    17
    Quote Originally Posted by evilamigo
    In that case, how do I force it to use the ndiswrapper driver?
    I'm just curious to know why are you so keen to use this particular driver? Is it a better driver than others or are there some special features regarding it? Certainly if it is so it will be good to get some more knowledge about it as you are already aware of it.

  7. #7
    Just Joined!
    Join Date
    Dec 2006
    Posts
    18
    try this:
    Code:
    rmmod b44
    modprobe ndiswrapper
    I tried this and it's still using the default driver (eth1 displays for iwconfig).

    What i don't understand is if the driver is already loaded, why do you want to force it to use ndiswrapper? Is the card not connecting or something?
    Well I installed linux and basically spent a while playing with the network settings before I googled for my particular card which led me to a bunch of tutorials on setting up ndiswrapper so I figured it was needed.

    Traditionally in Linux network cards are called ethX with X being a number, with the advent of ndiswrapper, it renames the network device to wlanX with wlan0 being the first wireless network card. If a Linux driver for the network card is used, regardless of if it is wired or wireless it is called ethX.
    Thankyou for the info.

    Also which distro are you running?
    openSUSE 10.2

    I'm just curious to know why are you so keen to use this particular driver? Is it a better driver than others or are there some special features regarding it? Certainly if it is so it will be good to get some more knowledge about it as you are already aware of it.
    I googled my particular wireless nic and found articles on ndiswrapper. I'm not sure what other options are available to me.


    Also what is the command to scan for wireless networks to see if my wireless nic can pick anything up (command line without using the gui.)

  8. #8
    Just Joined!
    Join Date
    Dec 2006
    Posts
    18
    Well I went and uninstalled the wireless network driver. iwconfig shows nothing now. I tried to reinstall ndiswrapper but I am not getting anything for iwconfig. In the post below, how do i "you have to go into your hardware manager and select your wireless card's drivers to ndiswrapper" ?

    I went to control center -> network card -> User controlled with networkmanager -> add -> wireless from pulldown -> select from list -> there isn't a ndiswrapper option

    I basically do this to install ndiswrapper..

    I had the exact same problem. I don't remember the exact forum and thread I got this info from, but this is how i got it to work for me.

    First, make sure you have ndiswrapper installed (I did it through YaST).
    then go here http://ndiswrapper.sourceforge.net/m...dex.php/List#B and find your cards drivers. If you have to extract from an exe use the command cabextract install.exe where install is the name of the exe.
    Then in a command shell log in as root and use ndiswrapper -i file/driver/ where file/driver is where your driver is.
    Then use ndiswrapper -m to prepare it for modprobe
    then use modprobe ndiswrapper and you should be able to connect to your wireless network with your Knetwork manager if you have it installed. It worked for me this way.
    you can go here: http://ndiswrapper.sourceforge.net/m....php/Main_Page for more info about ndiswrapper or if I forgot something and it dosn't work.

    oh and i forgot, you have to go into your hardward manager and select your wireless card's drivers to ndiswrapper
    Original post: http://www.linuxforums.org/forum/sus...ht=ndiswrapper

  9. #9
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    Ok, lets start clean now do the following:
    1. Install ndiswrapper via Yast i.e. from the SUSE cd/dvd
    2. Open up a terminal and copy the windows drivers to your home directory
    3. become root
    4. Execute these commands, if there is an error post back exactly what it says
    Code:
    ndiswrapper -i name_of_driver.inf
    ndiswrapper -l
    ndiswrapper -m
    modprobe ndiswrapper
    5. Look in iwconfig, if eth1 still appears, could you post back what lsmod returns.
    6. Goto Yast -> Network devices -> Network Card -> Select your card -> Hardware details. Here there will be a box called module, enter ndiswrapper here.
    7. Setup other stuff for the wireless card.

    As for scanning for wireless networks, execute following command
    Code:
    iwlist interface_name scan
    replace interface_name with name of network card i.e. eth1 or wlan0
    Life is complex, it has a real part and an imaginary part.

  10. #10
    Just Joined!
    Join Date
    Dec 2006
    Posts
    18
    0123456789
    [QUOTE=AlexK]
    Ok, lets start clean now do the following:
    1. Install ndiswrapper via Yast i.e. from the SUSE cd/dvd
    2. Open up a terminal and copy the windows drivers to your home directory
    3. become root
    4. Execute these commands, if there is an error post back exactly what it says
    Code:
    ndiswrapper -i name_of_driver.inf
    ndiswrapper -l
    ndiswrapper -m
    modprobe ndiswrapper
    No error.

    # ndiswrapper -i /home/tchase/b44win.inf
    installing b44win ...
    # ndiswrapper -l
    b44win driver installed, hardware (14E4:4401) present (alternate driver: b44)
    #ndiswrapper -m
    modprobe config already contains alias directive
    # modprobe ndiswrapper
    # iwconfig
    lo no wireless extensions

    sit0 no wireless extensions

    eth0 no wireless extensions

    5. Look in iwconfig, if eth1 still appears, could you post back what lsmod returns.
    6. Goto Yast -> Network devices -> Network Card -> Select your card -> Hardware details. Here there will be a box called module, enter ndiswrapper here.
    7. Setup other stuff for the wireless card.
    I deleted the hardware conf for my wireless card through YAST and then tried to install the ndiswrapper. I do not see any wireless extensions when i type iwconfig ;(

Page 1 of 3 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •