Find the answer to your Linux question:
Results 1 to 6 of 6
So, I've INSTALLED IPW3945 and all of it's dependencies. My advice to you if you're looking to do the same is to pay very close attention to the instructions, make ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2006
    Posts
    7

    Question IPW3945 +dependencies INSTALLED now what? Can't associate essid


    So, I've INSTALLED IPW3945 and all of it's dependencies. My advice to you if you're looking to do the same is to pay very close attention to the instructions, make obvious judgment calls and apply the patches.

    My problem is that I can't quite figure out how to actually associate my wifi connection.

    Here is a brief rundown of what I've installed (on Fedora 6):
    - ipw3945-1.1.3 +patches
    - ieee... +patches
    - wireless-tools
    - wpa_supplicant

    Basically I followed the instructions.


    # iwlist scan
    ...
    eth1 Scan completed :
    Cell 01 - Address: 00:14:BF:28:55:3D
    ESSID:"eric"
    Protocol:IEEE 802.11bg
    Mode:Master
    Channel:1
    Encryption key:on
    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
    11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
    48 Mb/s; 54 Mb/s
    Quality=97/100 Signal level=-29 dBm Noise level=-29 dBm
    IE: WPA Version 1
    Group Cipher : CCMP
    Pairwise Ciphers (1) : CCMP
    Authentication Suites (1) : PSK
    Extra: Last beacon: 12ms ago


    # iwconfig
    ...
    eth1 unassociated ESSID:"eric" Nickname:"localhost.localdomain"
    Mode:Managed Frequency=2.412 GHz Access Point: 00:14:BF:28:55:3D
    Bit Rate=0 kb/s Tx-Power:16 dBm
    Retry limit:15 RTS thr:off Fragment thr:off
    Encryption key:6572-6963-6572-6963-6572-6963-00 Security mode:restricted
    Power Management:off
    Link Quality:0 Signal level:0 Noise level:0
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:820 Missed beacon:0


    ---------------------------------------------------------------------------------------------

    I tried messing with the Network Manager but it isn't able to locate the driver. Directions at this point are scarce at best. Maybe I missed the memo since nobody else seems to be having trouble (or I'm in over my head)

  2. #2
    Just Joined!
    Join Date
    Dec 2006
    Posts
    7
    dmesg | grep ipw
    ipw3945: no version for "ieee80211_wx_get_encodeext" found: kernel tainted.
    ipw3945: Intel(R) PRO/Wireless 3945 Network Connection driver for Linux, 1.1.3d
    ipw3945: Copyright(c) 2003-2006 Intel Corporation
    ipw3945: Detected Intel PRO/Wireless 3945ABG Network Connection

    ------------------------------------------------------------------------------
    This may be the source of my troubles. I'll have to figure out why ieee... is having problems.

  3. #3
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    could you post back what these commands return:
    Code:
    ifconfig
    route
    ping -c 4 www.google.com
    Life is complex, it has a real part and an imaginary part.

  4. #4
    Just Joined!
    Join Date
    Dec 2006
    Posts
    7
    root@[/usr/src/ipw3945-1.1.3]: ifconfig
    eth0 Link encap:Ethernet HWaddr 00:E0:B8:C2:50:48
    inet addr:192.168.1.12 Bcast:192.168.1.255 Mask:255.255.255.0
    inet6 addr: fe80::2e0:b8ff:fec2:5048/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:7888 errors:0 dropped:0 overruns:0 frame:0
    TX packets:6483 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:7961006 (7.5 MiB) TX bytes:657032 (641.6 KiB)

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:4805 errors:0 dropped:0 overruns:0 frame:0
    TX packets:4805 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:5524110 (5.2 MiB) TX bytes:5524110 (5.2 MiB)

    peth0 Link encap:Ethernet HWaddr FE:FF:FF:FF:FF:FF
    inet6 addr: fe80::fcff:ffff:feff:ffff/64 Scope:Link
    UP BROADCAST RUNNING NOARP MTU:1500 Metric:1
    RX packets:7888 errors:0 dropped:0 overruns:0 frame:0
    TX packets:6458 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:7992558 (7.6 MiB) TX bytes:678338 (662.4 KiB)
    Interrupt:17

    vif0.0 Link encap:Ethernet HWaddr FE:FF:FF:FF:FF:FF
    inet6 addr: fe80::fcff:ffff:feff:ffff/64 Scope:Link
    UP BROADCAST RUNNING NOARP MTU:1500 Metric:1
    RX packets:6483 errors:0 dropped:0 overruns:0 frame:0
    TX packets:7888 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:657032 (641.6 KiB) TX bytes:7961006 (7.5 MiB)

    xenbr0 Link encap:Ethernet HWaddr FE:FF:FF:FF:FF:FF
    inet6 addr: fe80::200:ff:fe00:0/64 Scope:Link
    UP BROADCAST RUNNING NOARP MTU:1500 Metric:1
    RX packets:134 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:24999 (24.4 KiB) TX bytes:0 (0.0 b)

    root@[/usr/src/ipw3945-1.1.3]: route
    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use Iface
    192.168.1.0 * 255.255.255.0 U 0 0 0 eth0
    169.254.0.0 * 255.255.0.0 U 0 0 0 eth0
    default 192.168.1.1 0.0.0.0 UG 0 0 0 eth0
    root@[/usr/src/ipw3945-1.1.3]: ping -c 4 www.google.com
    PING www.l.google.com (66.102.7.99) 56(84) bytes of data.
    64 bytes from mc-in-f99.google.com (66.102.7.99): icmp_seq=1 ttl=246 time=12.8 ms
    64 bytes from mc-in-f99.google.com (66.102.7.99): icmp_seq=2 ttl=246 time=12.8 ms
    64 bytes from mc-in-f99.google.com (66.102.7.99): icmp_seq=3 ttl=246 time=12.7 ms
    64 bytes from mc-in-f99.google.com (66.102.7.99): icmp_seq=4 ttl=246 time=13.0 ms

    --- www.l.google.com ping statistics ---
    4 packets transmitted, 4 received, 0% packet loss, time 3004ms
    rtt min/avg/max/mdev = 12.798/12.887/13.001/0.135 ms



    ------------------------------------------------------------------------------------------------------------
    SOME ADDITIONAL INFO:

    2.6.18-1.2868.fc6-xen-i686
    ieee80211-1.2.15
    ipw3945-1.1.3

    Thanks,

  5. #5
    Just Joined!
    Join Date
    Dec 2006
    Posts
    7
    Also, modprobe is failing to load eth1 at startup. Most likely related to the above scenario. At this point I have to run ./load debug=0 to start ipw3945d. Running modprobe after startup doesn't seem to do anything:

    # modprobe ipw3945
    # ps -C ipw3945d
    PID TTY TIME CMD
    # cat /etc/modprobe.conf
    alias eth0 sky2
    alias scsi_hostadapter ahci
    alias snd-card-0 snd-hda-intel
    options snd-card-0 index=0
    options snd-hda-intel index=0
    remove snd-hda-intel { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-hda-intel
    alias peth0 sky2
    alias eth1 3c501
    install ipw3945 /sbin/modprobe --ignore-install ipw3945 ; sleep 0.5 ; /sbin/ipw3945d --quiet >> /etc/modules.d/ipw3945
    remove ipw3945 /sbin/ipw3945d --kill ; /sbin/modprobe -r --ignore-remove ipw3945 >> /etc/modules.d/ipw3945

  6. #6
    Just Joined!
    Join Date
    Dec 2006
    Posts
    7
    It's working! Well, sort of. I downloaded wifi-radar and after loading ipw3945d it was able to connect to a nearby access point (unsecure). I'll let the modprobe startup stuff slide for now and focus on the issue with my access point which uses WPA. My guess is that I haven't configured the WPA_Supplicant properly so I'll go ahead and review that now.

    I hope others in my situation find this thread useful.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •