Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16
I just installed Fedora Core 6 on a Compaq Presario V5000. The Compaq comes with an integrated wireless card -- the Intel 3945ABG card. Fedora Core 6 does not recognize ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2007
    Posts
    1

    Question Intel 3945ABG on Fedora Core 6 problem


    I just installed Fedora Core 6 on a Compaq Presario V5000. The Compaq comes with an integrated wireless card -- the Intel 3945ABG card. Fedora Core 6 does not recognize the card by default. How can I install the card under Fedora Core 6?
    I already found a howto but keep getting errors.
    I downloaded all files from the list below.


    In order to use the Intel PRO/Wireless 3945ABG Network Connection driver for Linux you will need the following:

    1. The binary microcode image, available here.
    2. The binary user space regulatory daemon, available here.
    3. The ieee80211 subsystem version 1.1.11 or newer.
    4. Linux kernel 2.6.13 or newer. See README.ipw3945 for information on specific options required to be enabled in the kernel.
    5. Wireless Extensions (v17) and Tools (v2
    6. For WPA you need a WPA supplicant compatible with the latest versions of the wireless extensions (v18 and newer).

    For instructions on how to build and use the driver, please see the INSTALL document.

    The INSTALL document contains the following information:

    2. QUICK INSTALL STEPS
    -----------------------------------------------

    The following provides steps that can be used to manually install and
    load the driver.

    Lines beginning with % can be run as any user. Lines beginning with #
    must be run as root.

    First, we build and install the ieee80211 subsystem. You can obtain
    the latest ieee80211 subsystem from http://ieee80211.sf.net. We
    recommend version 1.1.12 or newer:

    % tar xzvf ieee80211-1.1.14.tgz
    % cd ieee80211-1.1.14
    % make
    # make install <--- You may need to be root
    % cd ..
    The first error I get is when I use the command make:

    [root@thor ieee80211-1.1.14]# make
    Checking in /lib/modules/2.6.18-1.2869.fc6 for ieee80211 components...
    make -C /lib/modules/2.6.18-1.2869.fc6/build M=/root/Desktop/ieee80211-1.1.14 modules
    make[1]: Entering directory `/usr/src/kernels/2.6.18-1.2869.fc6-i586'
    CC [M] /root/Desktop/ieee80211-1.1.14/ieee80211_module.o
    /root/Desktop/ieee80211-1.1.14/ieee80211_module.c:34:26: error: linux/config.h: No such file or directory
    make[2]: *** [/root/Desktop/ieee80211-1.1.14/ieee80211_module.o] Error 1
    make[1]: *** [_module_/root/Desktop/ieee80211-1.1.14] Error 2
    make[1]: Leaving directory `/usr/src/kernels/2.6.18-1.2869.fc6-i586'
    make: *** [modules] Error 2



    If you encounter problems with the above, you may need to install the
    ieee80211 sources into your kernel and then build it as part of your
    kernel image. See the INSTALL and README.ieee80211 files provided in
    the ieee80211 subsystem package for more information.

    So I first have to install the ieee80211 sources into my kernel.
    I downloaded kernel-2.6.18-1.2798.fc6.src.rpm and ran the rpm file but still get the same error when I try to use make.
    Can anyone help me with this problem???

  2. #2
    Just Joined!
    Join Date
    Sep 2006
    Posts
    10

    Smile

    Hi..
    I too hav a similar problem..
    If i can get the soln i will let u know..
    Meanhile..if u are able 2 fix the pblm plz do lemme know.

    Thanks

  3. #3
    Just Joined!
    Join Date
    Jan 2007
    Posts
    1

    Lightbulb Solution that works

    Go to:
    http://atrpms.net/name/

    download and install these rpms
    ieee80211-kmdl-2.6.19-1.2895.fc6xen-1.2.16-16.fc6.at.i686.rpm
    ieee80211-kmdl-2.6.19-1.2895.fc6xen-1.2.16-16.fc6.at.x86_64.rpm
    ipw3945d-1.7.22-4.at.i386.rpm
    ipw3945-ucode-1.14.2-3.1.at.noarch.rpm
    ipw3945-kmdl-2.6.19-1.2895.fc6xen-1.2.0-18.2.fc6.at.i686.rpm
    ipw3945-1.2.0-18.2.fc6.at.i386.rpm


    Now, once you have installed all rpms successfully, ur done...do this in terminal/konsole:
    #depmod -a
    #modprobe ipw3945 <- this loads the module.
    to chk if its done do ...
    #dmesg | grep ipw <- this should list the driver detected.
    #lsmod <- this should list the driver detected. look for ipw3945
    OK now finally...
    #ps -C ipw3945 <- this should list the ipw3945d deamon running ...
    this means its running successfully and got loaded.
    else try,
    #/sbin/ipw3945d to start it ...
    thats it,
    now #system-config-network &
    select FILE>NEW>WIRELESS>FORWARD>SELECT UR DRIVER NOW LISTED> FORWARD> COMPLETE THE CONFIGURATION
    i.e. add ur essid, key etc and ok
    U R DONE ...
    its up and running , do #ifconfig it should show it running....displays its address and other details....

    u can also use iwconfig eth1 essid <xxx> -> look man pages for this i havent tried it out...

    You can use this method for most of intel drivers ...
    here are a few useful links -
    http://www.utexas.edu/its/wireless/i...fig_linux.html
    http://www.roseindia.net/linux/tutor...OWTO.html#toc5
    http://www.linuxquestions.org/linux/...Fedora_Core_5&
    http://tuxmobil.org/centrino.html

    http://ipw3945.sourceforge.net
    http://dl.atrpms.net/fc5-i386/atrpms/RPMS.stable/
    http://atrpms.net/dist/fc5/
    http://people.redhat.com/davej/kerne...5/RPMS.kernel/
    http://rpmforge.net/user/packages/

    References:
    http://www.linuxquestions.org/questi...d.php?t=436357
    http://www.linuxquestions.org/questi...=436355&page=2


  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Feb 2007
    Posts
    5

    Thank you!!

    Thanks iiaiiappa!! Great howto!

    I've been banging my head for 2 days trying to find a howto that actually works for this ipw3945 on FC6.

    I'm installing it on an Acer Travelmate 4670 and your directions work perfectly right up to adding it to the system-config-network.

    The module is loaded, the driver is detected, and I see the daemon running but when I go into the system-config-network gui the card is not visible or listed at all.

    Any ideas as to what's going on?

    Thanks!!

  6. #5
    Just Joined!
    Join Date
    Feb 2007
    Posts
    5

    never mind.....

    Sorry...It's visible now. All is good with the world again!

    Thanks!

  7. #6
    Just Joined!
    Join Date
    Mar 2007
    Posts
    7
    Another newbie trying to get the ipw3945 driver/card to work with fc6. I have followed the above instructions with the exception of installing some newer versions and I am still running into lots of problems.
    When I run
    [root@localhost ~]# yum --enablerepo=atrpms install ipw3945

    I get:
    Total download size: 17 M
    Is this ok [y/N]: y
    Downloading Packages:
    Running Transaction Test
    Finished Transaction Test


    Transaction Check Error: package kernel-2.6.19-1.2911.fc6 (which is newer than kernel-2.6.19-1.2895.fc6) is already installed
    package kernel-2.6.19-1.2911.6.4.fc6 (which is newer than kernel-2.6.19-1.2895.fc6) is already installed

    then:
    # modprobe ipw3945
    FATAL: Module ipw3945 not found.
    # /sbin/ipw3945d
    ipw3945d - regulatory daemon
    Copyright (C) 2005-2006 Intel Corporation. All rights reserved.
    version: 1.7.22
    2007-03-04 13:27:45: ERROR: ipw3945d already running. If ipw3945d is not running then you
    need to remove '/var/run/ipw3945d.pid' and try again.
    [root@localhost ~]# rm /var/run/ipw3945d.pid
    rm: remove regular file `/var/run/ipw3945d.pid'? y
    [root@localhost ~]# /sbin/ipw3945d
    ipw3945d - regulatory daemon
    Copyright (C) 2005-2006 Intel Corporation. All rights reserved.
    version: 1.7.22
    2007-03-04 13:28:53: ERROR: Could not find Intel PRO/Wireless 3945ABG Network Connection
    [root@localhost ~]# modprobe ipw3945
    FATAL: Module ipw3945 not found.
    [root@localhost ~]# depmod -a
    [root@localhost ~]# modprobe ipw3945
    FATAL: Module ipw3945 not found.


    Like I said, I am very new to linux/fedora so any ideas/advice would be great. So far I have tried a bunch of other howtos from this and other forums, the one above has seemed to be the closet to working.

    Also, I did notice that when fc6 is booting there is a line that reads:
    ipw3945d [OK]
    this is a good sign, right?

    I am installing this on an Acer aspire 5670 with the core duo and the ipw3945ABG wireless card.
    Thanks,
    Bahndo

  8. #7
    Just Joined!
    Join Date
    Feb 2007
    Posts
    5

    check your Kernel

    Check this out:
    http://fedoraproject.org/wiki/Bugs/F...97983a3822f143

    You may have the i586 Kernel installed and it sounds like you need the i686. It's a known bug with FC6. Just follow the directions on the above website and you should be good.

    I've made notes for my adventures trying to get the IPW cards running. Here's what my notes are..mostly copied from different websites.
    Start notes:
    -----------------------------
    Go to:
    http://atrpms.net/name/

    download and install these rpms
    ieee80211-kmdl-2.6.19-1.2895.fc6-1.2.16-16.fc6.at.i686.rpm
    ipw3945d-1.7.22-4.at.i386.rpm
    ipw3945-ucode-1.14.2-3.1.at.noarch.rpm
    ipw3945-kmdl-2.6.19-1.2895.fc6-1.2.0-18.2.fc6.at.i686.rpm
    ipw3945-1.2.0-18.2.fc6.at.i386.rpm

    Now, once you have installed all rpms successfully, ur done...do this in terminal/konsole:
    #depmod -a
    #modprobe ipw3945 <- this loads the module.
    to chk if its done do ...
    #dmesg | grep ipw <- this should list the driver detected.
    #lsmod <- this should list the driver detected. look for ipw3945
    OK now finally...
    #ps -C ipw3945 <- this should list the ipw3945d deamon running ...
    this means its running successfully and got loaded.
    else try,
    #/sbin/ipw3945d to start it ...
    thats it,
    now #system-config-network &
    select FILE>NEW>WIRELESS>FORWARD>SELECT UR DRIVER NOW LISTED> FORWARD> COMPLETE
    THE CONFIGURATION
    i.e. add ur essid, key etc and ok
    U R DONE ...
    its up and running , do #ifconfig it should show it running....displays its address and other details....
    ---------------------------------------
    end

    From another website,
    Start notes
    --------------------------------------

    Getting the wireless interface running
    Now we need to get three further mods done to get the wireless up and running:

    1. First we need to add three lines to the file /etc/modprobe.conf
    1. alias eth1 ipw3945
    2. install ipw3945 /sbin/modprobe --ignore-install ipw3945 ; sleep
    0.5 ; /sbin/ipw3945d --quiet
    3. remove ipw3945 /sbin/ipw3945d --kill ; /sbin/modprobe -r
    --ignore-remove ipw3945
    The first line assumes that we will have the wireless interface as eth1.
    2. Next we need to add a line to the file /etc/rc.local

    /sbin/ipw3945d --quiet

    This is critical since although the modules do load at boot the
    regulatory daemon does not run unless this change is made
    3. Finally we need to prepare a file to handle the interface eth1.

    Go into the directory /etc/sysconfig/network-scripts and prepare a file
    called ifcfg-eth1 (it may already exist)
    The file will have various parameters depending on whether you have wep
    security and which options you wish to set. My file looks like:
    1. # Please read /usr/share/doc/initscripts-*/sysconfig.txt
    2. # for the documentation of these parameters.
    3. ONBOOT=no
    4. USERCTL=yes
    5. PEERDNS=no
    6. TYPE=Wireless
    7. DEVICE=eth1
    8. HWADDR=xx:xx:xx:xx:xx:xx
    9. BOOTPROTO=dhcp
    10. ESSID=xxxxxxx
    11. KEY='xxxxxxxxxxxxxxxxxxxxxxxxxx restricted'
    12. MODE=Managed
    13. RATE=Auto
    14. PEERNTP=no
    The xxx here will be replaced by the values appropriate to your system.

    Once the system has booted with these changes, then first time after the
    re-boot you may need to do "depmod -a" as root, and then re-boot again.
    However if you are changing the driver or the regulatory daemon for a new
    version, you can do "modprobe -rv ipw3945" as root, then make the changes, and
    then "modprobe -av ipw3945" to reload the daemon. Then after logging on the
    wireless interface should be running and immediately give a network connection
    via the Access Point. Of course this presumes that the files /etc/resolv.conf,
    /etc/hosts, /etc/sysconfig/network have been amended to suit the network
    parameters of the local network. If network changes have been done, then as
    root type "service network restart" to update the system.

    The wireless network can be started or stopped by any user (since USERCTL has
    been set to yes in the ifcfg file) by doing /sbin/ifup eth1 or /sbin/ifdown
    eth1.

    In KDE a nice taskbar wireless monitor icon can be added using right click in
    the taskbar and then "add applet" - and selecting the Wireless Information
    applet

    -------------------------------------
    end notes

    Hope this helps some...sorry if the notes seem jumbled.

    You may also need to play around with the eth1 settings switching them from managed to Auto....

    These IPW drivers have really pissed me off lately....

    Good luck!

    Steve

  9. #8
    Just Joined!
    Join Date
    Mar 2007
    Posts
    7

    Almost there.... I think

    First off thanks a ton, I am getting closer. I followed the above steps, I do have the i686 kernel
    I have made the additions to the etc/modprobe.conf file, all seems to be good.
    The device and the driver are shown as eth1 in the GUI network manager.

    I added the /sbin/ipw3945d --quiet to the /etc/rc.local without any problems either.

    Now I am at the 3rd step.

    Go into the directory /etc/sysconfig/network-scripts and prepare a file
    called ifcfg-eth1 (it may already exist)
    There is no file ifcfg-eth1 (there is a ifcfg-eth0 file). So I need to create this file with the info from the above post (step 3),

    my problem now is that I am not sure where to find the xxx values for my computer/network. Is this something I can look up on the windows side of my computer (dual boot)? Also the wireless network is not encryped yet (that will be the next thing I do as soon as I get the wireless up and running), does that make a difference?

    Thanks again,

    Bahndo

  10. #9
    Just Joined!
    Join Date
    Mar 2007
    Posts
    7
    Oh yeah, when I try to configure the network using the network manager I get an error message:

    system-config-network
    The ethernet card could not be initialized. Please verify your setting and try again.
    followed by:

    Command failed: /sbin/modprobe ipw3945

    Output:
    FATAL: Module install not found.
    sleep: invalid option -- -

    Is this because I have not added the needed ifcfg-eth1 file?

    Thanks,

    Bahndo

  11. #10
    Just Joined!
    Join Date
    Feb 2007
    Posts
    5

    hhmmm

    Not sure....

    I don't remember if I configured the ifcfg-eth1 file or just let dhcp create it. I do remember that during the stratup messages, eth1 will NOT load. Once your logged in, go to:

    system -> administration -> Network

    Make sure eth1 is visible and you need to edit the eth1 config so that you switch between auto and managed. Not sure why but that started it up the first time. Then you reboot and it starts every time after that. Sorry...I'm trying to go off memory and I'm sure I'm leaving out details.

    Also, it sounds like the kernel module is not loaded....did you miss the kernel module rpm?

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •