Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 15 of 15
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined! Priest's Avatar
    Join Date
    Jun 2006
    Norwich, UK

    Hi again

    When I type /sbin/ifconfig on its own I get the output:

    [root@localhost Module]# /sbin/ifconfig
    eth0      Link encap:Ethernet  HWaddr 00:17:31:F3:71:E4
              UP BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
              Interrupt:50 Base address:0xa000
    lo        Link encap:Local Loopback
              inet addr:  Mask:
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:128 errors:0 dropped:0 overruns:0 frame:0
              TX packets:128 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0
              RX bytes:10160 (9.9 KiB)  TX bytes:10160 (9.9 KiB)
    [root@localhost Module]#
    No mention of ra0 at all. Tried /sbin/dhclient I got the same output as last time, left it for about 10/15 minutes and still nothing at all.

    I suppose there's no way around ifconfig? I don't understand what is going on, other people have got to have had this driver working and I'm on a pretty much 'out of the box' Mandriva 2007 x86_64 install. All my hardware works fine in Windoze so it shouldn't really be a problem with that. This is really really frustrating and without your help I wouldn't have even been able to get the module loaded (help I'm very grateful for by the way).

    Is there any part of my system I haven't thought to tell you about which might have an influence?

  2. #12
    Just Joined! Priest's Avatar
    Join Date
    Jun 2006
    Norwich, UK
    Oh, just adding a bit more

    I added "rt61" to the end of /etc/modules to load it evey time I booted, I've just rebooted and I tried lsmod again. rt61 wasnt there at all.

    Is there something else I should be adding to the line as well?

  3. #13
    I made a slight error in asking you to type sbin/ifconfig. I meant sbin/iwconfig ifconfig is the command to list wired connections, not wireless connections. Try that.

    As for the /etc/modules.conf thingy, I have no idea. You did edit the file as root, right?

    Also, here's a biased statement that you don't necessarily have to listen to:

    I don't like Mandriva. It's just not as good as some of the other distros. Also, it's hits per day on distrowatch have been dropping quite a bit lately. It is fading away, and other distros like Gentoo and Ubuntu are taking it's place. Personally, I think Ubuntu is the best Linux distro for home use. It just works (and I think apt package management is better than rpm). If all else fails, use Ubuntu.

    (end of biased statement)

  4. $spacer_open
  5. #14
    Just Joined! Priest's Avatar
    Join Date
    Jun 2006
    Norwich, UK

    Thanks for your advice, I've been looking at Ubuntu and heard several good things about it. I'm certainly not adverse to giving it a try (well, Kubuntu. I like KDE)

    I don't necessarily have undying loyalty for Mandriva, it was just that Mandrake 10.1 was the first distro I tried that didn't give me an error a minute so to speak. I've stayed with them since. But I love the Linux system in general. The workings of it and the ideals behind it, so I'm eager to make the switch from Windoze as soon as I get working wireless, to whichever distro works better for me. Plus the Ubuntu project seems to be a bit more community based than Mandriva, which is nice

    If I cant get past the same step on Kubuntu I'll be posting on here again tonight

  6. #15
    Just Joined! Priest's Avatar
    Join Date
    Jun 2006
    Norwich, UK

    Red face

    Hi again

    I've been a bit quiet over the last week as I've been trying out several things.

    First of all, I installed Kubuntu 6.10. I tried all the steps on that and it kept failing at the same point. So the new distro didn't really help there. Also, there were several things I quite liked about the interface, sudo for one. and only seeing the home folder and media folder (seemed quite neat and tidy). But it gave me a lot of trouble with things like the nVidia driver (which worked first time in Mandriva) and I missed the Mandriva Control Centre. So for now I'm back with that, although once I've finally found a way to do this internet and managed to leave Windoze for linux, I'll dual boot some distros and properly find out which suits me best.

    Whilst on the Ubuntu forums I found a thread about this very driver. And from this I managed to find out what my main problem was. The driver doesn't work on x86_64! Only 32-Bit distros. There was a link however to a project supposed to bring 64bit support to the driver here.

    I tried the project but it failed to work on my system. But then again it did say that it was mainly untested and never guaranteed to work.

    I made the decision to download the 32bit Mandriva finally. It seemed a bit of a waste as I've only recently upgraded to a 64bit processor but I was also having 64bit compatibility issues with some other software I use such as Blender (a 3D rendering and animation program I simply can't do without). Are there any advantages to having a 64bit distro and do the improvements outweigh the problems in your opinion?

    Anyway, now I'm using the i586 version I followed the readme instructions and everything went through without a hitch. From iwconfig I now get this:

    [root@localhost priest]# iwconfig
    lo        no wireless extensions.
    eth0      no wireless extensions.
    sit0      no wireless extensions.
    ra0       RT61 Wireless  ESSID:""
              Mode:Auto  Frequency:1 MHz  Bit Rate=54 Mb/s
              RTS thr:off   Fragment thr:off
              Encryption key:off
              Link Quality=0/100  Signal level:-121 dBm  Noise level:-111 dBm
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0
    Yay! To my untrained eye it looks like it is recognising my card. However I still get the problem of it not loading at boot. Even though it's been added the the /etc/modules file. The next big question is, how do I get it to connect to my network? The wireless configuration in the GUI is not showing my card as an option (just install new with ndiswrapper). I have altered the configuration file the readme directed me to and it now looks like this. (obviously with some of my WEP key hidden (god knows who could be in my drive with a laptop )):

    That's as much as I could figure out to enter from the readme and its obviously not connecting as I have no internet and iwconfig says: ESSID="" and not: ESSID="sharpe". Having said that, I don't know if that is the way to test a network connection.

    I feel that working internet is so close now I can taste it. I've tried to figure out as much as I can on my own but could you offer any help to get me over this last hurdle?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts