Find the answer to your Linux question:
Results 1 to 4 of 4
Hello I am trying to install Madwifi on a laptop running FC6. I am following these instructions. However, after typing "make", I get the following problem: [root@Vigor17 madwifi-0.9.2.1]# make Checking ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2006
    Posts
    9

    Help installing Madwifi on Fedora Core 6


    Hello

    I am trying to install Madwifi on a laptop running FC6. I am following these instructions. However, after typing "make", I get the following problem:

    [root@Vigor17 madwifi-0.9.2.1]# make
    Checking requirements... ok.
    Checking kernel configuration... ok.
    make -C /lib/modules/2.6.19-1.2895.fc6/build SUBDIRS=/home/neil/madwifi-0.9.2.1 modules
    make[1]: Entering directory `/usr/src/kernels/2.6.19-1.2895.fc6-i686'
    CC [M] /home/neil/madwifi-0.9.2.1/ath/ah_osdep.o
    In file included from /home/neil/madwifi-0.9.2.1/ath/ah_osdep.c:2:
    /home/neil/madwifi-0.9.2.1/ath/../hal/linux/ah_osdep.c:44:26: error: linux/config.h: No such file or directory
    make[3]: *** [/home/neil/madwifi-0.9.2.1/ath/ah_osdep.o] Error 1
    make[2]: *** [/home/neil/madwifi-0.9.2.1/ath] Error 2
    make[1]: *** [_module_/home/neil/madwifi-0.9.2.1] Error 2
    make[1]: Leaving directory `/usr/src/kernels/2.6.19-1.2895.fc6-i686'
    make: *** [modules] Error 2
    Please could someone help me?

  2. #2
    Linux Guru Vergil83's Avatar
    Join Date
    Mar 2004
    Posts
    2,407
    You might look at http://madwifi.org/wiki/UserDocs/Distro/RedHat (it should be easier)
    Brilliant Mediocrity - Making Failure Look Good

  3. #3
    Just Joined!
    Join Date
    Oct 2006
    Posts
    9
    Thanks!

    However, one slight hiccough. I installed madwifi-devel-0.9.3-31_r1865.fc6.at.i386.rpm fine, but when installing madwifi-0.9.3-31_r1865.fc6.at.i386.rpm, I got the error
    [root@Vigor17 Desktop]# rpm -i madwifi-0.9.3-31_r1865.fc6.at.i386.rpm
    warning: madwifi-0.9.3-31_r1865.fc6.at.i386.rpm: Header V3 DSA signature: NOKEY, key ID 66534c2b
    error: Failed dependencies:
    madwifi-kmdl-1:0.9.3-31_r1865.fc6.at is needed by madwifi-0.9.3-31_r1865.fc6.at.i386
    I checked both ATrpms and google for madwifi-kmdl-1:0.9.3-31_r1865.fc6.at, but to no avail.

    I'm sorry for the nuisence and I apprieciate your time.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru Vergil83's Avatar
    Join Date
    Mar 2004
    Posts
    2,407
    I found some at http://rpm.pbone.net/index.php3 (search for madwifi-kmdl)
    Brilliant Mediocrity - Making Failure Look Good

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •