Find the answer to your Linux question:
Results 1 to 2 of 2
Hello. I have bought a Zyxel G-202 and I'm trying install this on Debian (etch). I think the driver is installed but when I plug in the wlan I don't ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2007
    Posts
    1

    Getting Zyxel G-202 (wireless USB) to work


    Hello.
    I have bought a Zyxel G-202 and I'm trying install this on Debian (etch). I think the driver is installed but when I plug in the wlan I don't get any new devices.
    There is not much info about this card on the net. On a few pages it's writen that it has the right chipset.

    However both G-220 and G-200. shoul be compatible with the zd1211 driver.

    The driver seemed to be installed correctly. But I do not know if I should have done something before compiled the "zd1211" driver OR before I used modconf and istalled it to the kernel.

    However when I plug in and plug out the stick , I can see through dmesg that the usb ports are at least working.

    Acording to the file zdusb.h it is needed to add some values. But which in that case.

    /* Define these values to match your device */
    #define VENDOR_ZYDAS 0x0ACE //ZyDAS
    #define PRODUCT_1211 0x1211
    #define PRODUCT_A211 0xa211
    #define VENDOR_ZYXEL 0x0586 //ZyXEL
    #define PRODUCT_G220 0x3401
    #define VENDOR_3COM 0x6891
    #define PRODUCT_A727 0xA727
    #define PRODUCT_G220F 0x3402

    Please help If anyone got an idea.

    P.S I'm rather new to linux and I am a Windows user. But I'm working hard.

  2. #2
    Just Joined!
    Join Date
    Feb 2007
    Posts
    1

    Thumbs up

    Hi Alex,

    I had the same problem recently. I modified and recompiled the zd1211rw driver and I was even able to get iwconfig to regocnize the g-202. However, I never got it working: I couldn't make it associate with my wireless access point nor to get IP address for it.

    But the I found something called ndiswrapper that can use the original windows drivers from zyxel. And this did the trick, now the g-202 works nicely and I got it also activating automatically during the boot after playing a bit with /etc/sysconfig files. Just download the driver from zyxel website and follow instructions here
    http://ndiswrapper.sourceforge.net/m...p/Installation

    My system is fedora6 but I guess it should work also in your case.

    btw. in case of zd1211rw you need to modify zd_usb.c file by adding this line

    { USB_DEVICE(0x0586, 0x3410), .driver_info = DEVICE_ZD1211 },

    where that value for USB_DEVICE is is what you see with lsusb command.
    This needs to be added to static struct usb_device_id usb_ids[] -definitions. Then I just recompiled the thing, did
    make ins
    and
    modprobe -v zd1211rw.

    to load the module. Then with ifconfig, iwscan and iwconfig I tried configuring and activating it, but there I run out of luck and eventually found the ndiswrapper.

    hope this helps
    -julle

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •