Find the answer to your Linux question:
Results 1 to 3 of 3
I'm trying to get my Intel Pro/Wireless 3945ABG wireless card to work on Fedora Core 6. I'm completely new to Linux; basically trying to get my wireless working is the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2007
    Posts
    2

    newbie question: Intel Pro/Wireless 3945ABG on Fedora Core 6


    I'm trying to get my Intel Pro/Wireless 3945ABG wireless card to work on Fedora Core 6. I'm completely new to Linux; basically trying to get my wireless working is the first thing I've done in Linux besides installing it, so forgive my ignorance.

    I've googled this topic and found a few different ways of setting it up. First I tried the way at http://ipw3945.sourceforge.net/ using the install options at http://ipw3945.sourceforge.net/INSTALL . For one thing all this .tgz and .rpm stuff is completely new to me and i cant say i really understand what i'm doing other than typing in what the howtos tell me to. So I downloaded ieee80211-1.2.16.tgz . The tutorial uses ieee80211-1.1.14.tgz , but i assumed it was a little outdated and that i should download the latest (stable -- i think) version, and i continued to follow this logic on all steps.. is this correct? So anyway, the first major problem i came to in this tutorial was where it says:

    Finally we can check to see if things worked:

    # iwconfig eth1
    I get a message saying "iwconfig: command not found". I wasnt really sure if i had done everything up to that point correctly though, so i went looking for other howtos. The last thing I tried and felt the most comfortable with comment 3 here http://www.linuxforums.org/forum/wir...6-problem.html

    download and install these rpms
    ieee80211-kmdl-2.6.19-1.2895.fc6xen-1.2.16-16.fc6.at.i686.rpm
    ieee80211-kmdl-2.6.19-1.2895.fc6xen-1.2.16-16.fc6.at.x86_64.rpm
    ipw3945d-1.7.22-4.at.i386.rpm
    ipw3945-ucode-1.14.2-3.1.at.noarch.rpm
    ipw3945-kmdl-2.6.19-1.2895.fc6xen-1.2.0-18.2.fc6.at.i686.rpm
    ipw3945-1.2.0-18.2.fc6.at.i386.rpm
    I did this, except fwith some different versions. The ones I installed were:

    ieee80211-kmdl-2.6.19-1.2911.fc6xen-1.2.16-17.fc6.at.i686.rpm
    ipw3945d-1.7.22-4.at.i386.rpm
    ipw3945-ucode-1.14.2-4.at.noarch.rpm
    ipw3945-kmdl-2.6.19-1.2911.fc6xen-1.2.0-18.2.fc6.at.i686.rpm
    ipw3945-1.2.0-18.2.fc6.at.i386.rpm

    In that order. I didn't install the 2nd one in the list initially because of the 64 on the end and i'm on a 32 bit processor, and i thought that looked like it was for a 64 bit processor.. do i skipped that one. After installing i continued the steps, but they didn't work, so i went back and downloaded

    ieee80211-kmdl-2.6.19-1.2911.fc6xen-1.2.16-17.fc6.at.x86_64.rpm

    But when i try to install it says it already is ? im pretty sure i didnt install it but maybe i did in some capacity earlier when i was trying other tutorials... anyway, the rpm tells me its installed. The errors I get in the steps after installation of the RPMs are below. Heres the section of his comment for reference:

    Now, once you have installed all rpms successfully, ur done...do this in terminal/konsole:
    #depmod -a
    #modprobe ipw3945 <- this loads the module.
    to chk if its done do ...
    #dmesg | grep ipw <- this should list the driver detected.
    #lsmod <- this should list the driver detected. look for ipw3945
    OK now finally...
    #ps -C ipw3945 <- this should list the ipw3945d deamon running ...
    this means its running successfully and got loaded.
    else try,
    #/sbin/ipw3945d to start it ...
    thats it,
    Here's what I get:

    [Hamato@192 ~]$ depmod -a
    bash: depmod: command not found
    [Hamato@192 ~]$ modprobe ipw3945
    bash: modprobe: command not found
    [Hamato@192 ~]$ dmesg | grep ipw
    [Hamato@192 ~]$ lsmod
    bash: lsmod: command not found
    [Hamato@192 ~]$ ps -C ipw3945
    PID TTY TIME CMD
    [Hamato@192 ~]$ /sbin/ipw3945d
    ipw3945d - regulatory daemon
    Copyright (C) 2005-2006 Intel Corporation. All rights reserved.
    version: 1.7.22
    2007-02-17 16:54:52: ERROR: Could not find Intel PRO/Wireless 3945ABG Network Connection
    Anyone hve any ideas? iwconfig still doesnt work for me. Why is that? I'd really appreciate any help. Thanks.

  2. #2
    Just Joined!
    Join Date
    Feb 2007
    Posts
    2

    easier distro

    Also, is there a distro that would already recognize Intel Pro/Wireless straight from the installation? Or would it be easier for a newbie like me in some other distro?

  3. #3
    Just Joined!
    Join Date
    Feb 2007
    Posts
    2
    HI there! I'm pretty new too, and I had the same issue with FC6. I ended up finding the installations for my wireless card (same one) in rpm format (check on freshrpms, I think that's where I found it). The rpm format is like a "packaged" install...

    On another note... Being new to Linux, I found Fedora a little intimidating to use. I downloaded openSUSE 10.2, and for me at least, it's been a whole lot easier (and my wireless card was recognized straight away)

    Take care and good luck to you!

    George

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •