Find the answer to your Linux question:
Results 1 to 5 of 5
A little over a year ago I installed Suse 9.x (don't remember) and had major issues getting my Belkin 54g FSD7010 working on my Dell Inspiron 2650. After days of ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2007
    Posts
    4

    eth1 not wlan0 - Belkin 54g not working


    A little over a year ago I installed Suse 9.x (don't remember) and had major issues getting my Belkin 54g FSD7010 working on my Dell Inspiron 2650.
    After days of searching I was told that it was because Suse was not recognising the wireless card as a wireless device and/or the inbuilt physical device was interfering.

    I was given a command that disabled the wired port and allowed the wireless device to work. I replace the laptop not long after. Now, wanted to use it again, I did a clean install of Suse 10.2, wiping away my past efforts.

    In a vain attempt the make the card work, and not finding advice similar to the advice I had received all the time ago, I installed ndiswrapper. Confused as to why I didn't have to do this last time and a generic driver that came with Suse had it going, I pressed on.
    I downloaded 2 corresponding drivers from the ndiswrapper wiki list. 1 that said it was for Broadcom xxx chipset and another that said it was for the Belkin FSD7000 card. I also took the driver from the accompanying CD. The 2 downloaded were shown to be invalid by the ndiswrapper -l command and the one from the CD gave me this confirmation:
    bcmwl5 : driver installed
    device (14E4:4320) present (alternate driver: bcm43XX)



    Now, the card does not light up, and checking the system log I see:
    Linux kernel: bcm43xx: PHY connected
    Linux firmware.sh[4230]: Cannot find firmware file 'bcm43xx_microcode.fw'
    Linux kernel: bcm43xx: Error: Microcode "bcm43xx_microcode4.fw" not available or load failed




    Why did I never need to use ndiswrapper before? (aha! I think I had only 11mbps and didnt care - dodgy driver - ndiswrapper should help then)

    What is this ndiswrapper error and how do i fix it?

    Is it a problem that I have from iwconfig:
    eth0 no wireless extensions
    eth1 IEEE 802.11b/g ESSID:"...



    Thanks.

  2. #2
    Just Joined!
    Join Date
    Mar 2005
    Location
    Washington State, US
    Posts
    6
    I use Slack myself so things are bound to be a bit different but at this site you can find your particular driver: http://ndiswrapper.sourceforge.net/m...index.php/List

    For mine there were two files, a .sys and .inf file.

    You correctly loaded the file with modprobe if driver is present but you may need to blacklist the bcm43xx from loading. On slack its /etc/modprobe.d/blacklist and the text would be "blacklist bcm43xx" at the bottom of the file. Also you will want to edit your wireless card configuration which again in slack (dont know suse direct.) is in /etc/rc.d/rc.wireless.conf
    An example would look like this:
    Code:
    case "$ADDRESS" in
              *,0,*,*)
                 INFO="Sample network setup"
                 IPADDR="10.42.7.2"
                 NETMASK="255.255.255.192"
                 NETWORK="10.1.1.0"
                 BROADCAST="10.1.1.255"
                 GATEWAY="10.1.1.1"
                 ;;
              esac
    and i configured my configuration for network settings /etc/rc.d/rc.inet1.conf
    Code:
    # Config information for eth0:
    IPADDR[0]=""
    NETMASK[0]=""
    USE_DHCP[0]="yes"
    DHCP_HOSTNAME[0]=""
    # Default gateway IP address:
    GATEWAY=""
    DEBUG_ETH_UP="no"
    
    
    IFNAME[4]="wlan0"
    IPADDR[4]=""
    NETMASK[4]=""
    USE_DHCP[4]="yes"
    DHCP_HOSTNAME[4]="bcm43xx"
    DHCP_KEEPRESOLV[4]="yes"
    DHCP_KEEPNTP[4]="yes"
    DHCP_KEEPGW[4]="yes"
    DHCP_IPADDR[4]=""
    WLAN_ESSID[4]=BARRIER05
    WLAN_MODE[4]=Managed
    WLAN_RATE[4]="54M auto"
    WLAN_CHANNEL[4]="auto"
    ##WLAN_KEY[4]="D5AD1F04ACF048EC2D0B1C80C7"
    ##WLAN_IWPRIV[4]="AuthMode=WPAPSK EncrypType=TKIP WPAPSK=7B1ABEEB5D197741923ED26727569C365E31212096A0EAFAD563B268BAD01CAF TxRate=0"
    #WLAN_WPA[4]="wpa_supplicant"
    WLAN_WPADRIVER[4]="ndiswrapper"
    Like I said before, I dont know if these files are located in similar directories in Suse but this is the general idea. Make sure ndiswrapper loads with the kernel at startup by adding it to the modprobe list. After all this you should be able to use wireless tools to simply type "iwconfig wlan0" into the terminal. Shoot... hope any of that helps.

  3. #3
    Just Joined!
    Join Date
    Feb 2007
    Posts
    4
    Thanks for the reply.
    I've taken off the bcm43xx stuff completely - well I unloaded each and every driver and started again.

    I reinstalled bcmwl5, a driver from another location then set "ndiswrapper" as the driver, which I assume uses bcmwl5.

    Well, it now seems to work, at 54mbps too it seems...

    Code:
    eth1      Scan completed :
              Cell 01 - Address: 00:11:F5:4D:5A:68
                        ESSID:"2719053"
                        Protocol:IEEE 802.11b
                        Mode:Managed
                        Frequency:2.412 GHz (Channel 1)
                        Quality:53/100  Signal level:-62 dBm  Noise level:-96 dBm
                        Encryption key:on
                        Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                                  24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
                                  12 Mb/s; 48 Mb/s
                        Extra:bcn_int=100
                        Extra:atim=0

    Well... I have a new problem... Each time I restart the computer I must reset the WEP key and rescan.

    Code:
    Linux:/home/x/Desktop # iwconfig eth1 key open 20AE8A7051
    Linux:/home/x/Desktop # iwlist scan
    What can I do to make this stick?

    Thanks again?

  4. #4
    Just Joined!
    Join Date
    Feb 2007
    Posts
    4
    /etc/sysconfig/network

    ifcfg-eth-id-<MAC>

    added lines:

    WIRELESS_ESSID='<netname>'
    WIRELESS_KEY='<WEP-KEY>'



  5. #5
    Just Joined!
    Join Date
    Mar 2005
    Location
    Washington State, US
    Posts
    6
    Ceviche,

    I assume by your response that it is loading the WEP key now that you have entered it into /etc/sysconfig/network? That would have been my response to your question had I been quicker to check the forum. I personally don't use WEP as I live in a rural area with hillbilly's who wouldn't know how to activate a wireless card if they even could find the power switch on their desktop/laptop. I hear that WPA is a much better encryption as WEP keys are easily found through dictionary attacks(long method) and the collection of large amounts of frames data in order to deduce the secret key. I think you might be better off going with WPA if possible.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •