Find the answer to your Linux question:
Page 5 of 10 FirstFirst 1 2 3 4 5 6 7 8 9 ... LastLast
Results 41 to 50 of 97
I used the `ndiswrapper -r` command to remove all the installed "drivers" except the one .inf file from the drivers folder on my adapters CD. Now when I type ndiswrapper ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #41
    Just Joined! ezkimo's Avatar
    Join Date
    Feb 2007
    Posts
    60

    I used the `ndiswrapper -r` command to remove all the installed "drivers" except the one .inf file from the drivers folder on my adapters CD.

    Now when I type ndiswrapper -l to see if it is working I get this :
    [root@localhost WDrivers]# ndiswrapper -l
    installed drivers:
    net5211 invalid driver!

    On the CD for the adapter in the driver's folder their are the following files :
    ar52119x.sys
    ar5211.sys
    net5211.cat
    net5211.inf

    The net5211.inf was the one I installed.
    Since I installed the only .inf file could it be that another one of these needs to be installed? If so which one and if not What is my next step?

  2. #42
    Linux User Daan's Avatar
    Join Date
    Aug 2005
    Location
    The Netherlands
    Posts
    323
    Hi ezkimo. I had the same problem, ndiswrapper told me I had an invallid driver. This happened after I told it to install a .inf that didn't exist. I could not remove it using the -r option. I could also not reinstall it when I did have that .inf file. I then manually removed the /etc/ndiswrapper/something directory that ndiswrapper had made for the non-present .inf file (it was an empty directory). After that, I could install it properly.

    Still don't have it working under Linux though. iwconfig doesn't show any wireless things...

  3. #43
    Just Joined! ezkimo's Avatar
    Join Date
    Feb 2007
    Posts
    60
    Thanks man... it worked!!!

    [root@localhost WDrivers]# ndiswrapper -i net5211.inf
    installing net5211 ...
    [root@localhost WDrivers]# ndiswrapper -l
    installed drivers:
    net5211 driver installed

    Then I modprobed to see if their were any errors and got this :

    [root@localhost WDrivers]# modprobe ndiswrapper
    [root@localhost WDrivers]#

    Which indicates their are no problems.
    I then tried to establish the SIDD and WPA key to find out their are no wlan devices

    Now that the driver is installed, any idea on how to get my wlan device recognized?

  4. #44
    Just Joined! ezkimo's Avatar
    Join Date
    Feb 2007
    Posts
    60
    When I tried to establish the SSID I got this :

    [root@localhost ~]# iwconfig wlan0 essid "MySSID"
    Error for wireless request "Set ESSID" (8B1A) :
    SET failed on device wlan0 ; No such device.

    Even though the driver is properly installed...

  5. #45
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Post the output of these commands
    ifconfig
    dmesg | tail
    less /etc/modprobe.conf
    ls /etc/sysconfig/network-scripts
    EDIT: changed iwlist to ifconfig
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  6. #46
    Just Joined! ezkimo's Avatar
    Join Date
    Feb 2007
    Posts
    60
    [root@localhost ~]# ifconfig
    eth0 Link encap:Ethernet HWaddr 00:14:22:BB:3F:3F
    inet addr:192.168.1.101 Bcast:192.168.1.255 Mask:255.255.255.0
    inet6 addr: fe80::214:22ff:febb:3f3f/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:19298 errors:0 dropped:0 overruns:0 frame:0
    TX packets:17476 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:19171005 (18.2 MiB) TX bytes:2590084 (2.4 MiB)
    Interrupt:11

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:1729 errors:0 dropped:0 overruns:0 frame:0
    TX packets:1729 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:2655372 (2.5 MiB) TX bytes:2655372 (2.5 MiB)

    [root@localhost ~]# dmesg | tail
    mtrr: 0xe8000000,0x8000000 overlaps existing 0xe8000000,0x2000000
    mtrr: 0xe8000000,0x8000000 overlaps existing 0xe8000000,0x2000000
    mtrr: 0xe8000000,0x8000000 overlaps existing 0xe8000000,0x2000000
    agpgart: Found an AGP 2.0 compliant device at 0000:00:00.0.
    agpgart: Putting AGP V2 device at 0000:00:00.0 into 1x mode
    agpgart: Putting AGP V2 device at 0000:01:00.0 into 1x mode
    [drm] Setting GART location based on new memory map
    [drm] Loading R200 Microcode
    [drm] writeback test succeeded in 2 usecs
    pccard: card ejected from slot 0

    [root@localhost ~]# less /etc/modprobe.conf
    alias eth0 b44
    alias eth1 ipw2200
    alias snd-card-0 snd-intel8x0
    options snd-card-0 index=0
    options snd-intel8x0 index=0
    remove snd-intel8x0 { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; }; /sbin/
    modprobe -r --ignore-remove snd-intel8x0
    /etc/modprobe.conf (END)

    [root@localhost ~]# ls /etc/sysconfig/network-scripts
    ifcfg-eth0 ifdown-ipv6 ifup ifup-isdn ifup-tunnel
    ifcfg-eth1 ifdown-isdn ifup-aliases ifup-plip ifup-wireless
    ifcfg-lo ifdown-post ifup-bnep ifup-plusb init.ipv6-global
    ifdown ifdown-ppp ifup-eth ifup-post net.hotplug
    ifdown-bnep ifdown-routes ifup-ippp ifup-ppp network-functions
    ifdown-eth ifdown-sit ifup-ipsec ifup-routes network-functions-ipv6
    ifdown-ippp ifdown-sl ifup-ipv6 ifup-sit
    ifdown-ipsec ifdown-tunnel ifup-ipx ifup-sl

  7. #47
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    It looks like you should be using eth1 instead of wlan0
    Try iwconfig eth1 essid "MySSID"
    If this still fails then you can do it manually by editting /etc/sysconfig/network-scripts/ifcfg-eth1
    EDIT: you'll probably need to disable the eth0 before eth1 will operate via DHCP.
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  8. #48
    Just Joined! ezkimo's Avatar
    Join Date
    Feb 2007
    Posts
    60
    I thought the eth0 was my wired connection.

  9. #49
    Linux User Oxygen's Avatar
    Join Date
    Jul 2004
    Location
    Hartlepool, England
    Posts
    392
    He said eth ONE eth1.

    BTW ndiswrapper -r won't do alot, because the remove driver command is ndiswrapper -e. Just an FYI.
    Graham - You'd better Use Linux!

    I'm registerd Linux user #397030. What about you?

  10. #50
    Just Joined! ezkimo's Avatar
    Join Date
    Feb 2007
    Posts
    60
    I tried with eth1 and got this :
    [root@localhost ~]# iwconfig eth1 essid "MySSID"
    Error for wireless request "Set ESSID" (8B1A) :
    SET failed on device eth1 ; No such device.

    When I attempted to edit the file you specified I realized it was for the wrong wireless adapter... it is for ipw2200 which is my on board. The one I am trying to get working first is the D-Link adapter.
    The file contained :
    # Intel Corporation PRO/Wireless 2200BG Network Connection
    DEVICE=eth1
    ONBOOT=yes
    BOOTPROTO=dhcp
    TYPE=Ethernet
    USERCTL=no
    IPV6INIT=no
    PEERDNS=yes

Page 5 of 10 FirstFirst 1 2 3 4 5 6 7 8 9 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •