Find the answer to your Linux question:

View Poll Results: Have you got this adaptor to work yet?

Voters
9. You may not vote on this poll
  • Yes

    3 33.33%
  • No

    3 33.33%
  • Almost

    3 33.33%
Page 5 of 11 FirstFirst 1 2 3 4 5 6 7 8 9 ... LastLast
Results 41 to 50 of 108
It most likely means that you don't have your kernel source files installed. In Konsole, type; Code: ls /lib/modules/`uname -r`/build (those things around "uname -r" aren't inverted commas. You'll find ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #41
    Just Joined!
    Join Date
    Mar 2007
    Location
    North Yorkshire, UK
    Posts
    31

    It most likely means that you don't have your kernel source files installed.

    In Konsole, type;

    Code:
    ls /lib/modules/`uname -r`/build
    (those things around "uname -r" aren't inverted commas. You'll find the key next to the "1" key.
    Or you can copy this line straight into console.

    Make sure that there's a folder called "include", and a file called ".config"

    If not, then go to YaST, and search for "kernel-default"
    See if there's a tick next to it. If not, then install it and do the make again for ndiswrapper.

  2. #42
    Linux User martinfromdublin's Avatar
    Join Date
    Dec 2004
    Location
    Dublin, Rep. of Ireland
    Posts
    446
    Hi again Falcifer,

    Sorry for the delay,I was watching the Ireland/Slovakia match (Ireland won). I updated the kernel using the online updates and ran that command, here's all it produced;

    Module.symvers

    When I search YaSt for kernel-defaults nothing is found but I had to reboot for the new kernel take effect so maybe I should give the 'make' another go. How do I get back into the ndiswrapper folder?

    Martin
    LINUX: Where do you want to go.......Tomorrow!

    Registered Linux user 396633

  3. #43
    Just Joined!
    Join Date
    Mar 2007
    Location
    North Yorkshire, UK
    Posts
    31
    What did you type in the YaST search?
    if you just type "kernel-default" (no "S"), you should see something.
    Or just "kernel"...

    You can try using the update. Click on the ticked box (if it's ticked), so that it shows a "Z"-type thing.
    Also, check to see if the "kernel-source" is installed.

    If you updated the kernel, then you should run ./configure, and make again.

    But you do need the "include" folder and ".config" file in the "/lib/modules/2.6.18.3-24-default/build" folder. At the moment, you only have the file "Module.symvers", which is what that output means.

    And finally... to get to a folder use

    Code:
    cd /home/martin/folders/ndiswrapper-1.39

  4. #44
    Linux User martinfromdublin's Avatar
    Join Date
    Dec 2004
    Location
    Dublin, Rep. of Ireland
    Posts
    446
    Hi again,

    Am I looking in the right place? When I open YaST there is a button in the bottom left hand corner marked 'search', I click that and then enter 'kernel-default' or 'kernel' and the words 'nothing found' display. I tried checking the online update and I have neither 'kernel' nor 'kernel-source' available to me. I'm a bit lost now..

    PS: If I don't answer tonight,will do so tomorrow, have to be up for work in the morning.

    Martin
    LINUX: Where do you want to go.......Tomorrow!

    Registered Linux user 396633

  5. #45
    Just Joined!
    Join Date
    Mar 2007
    Location
    North Yorkshire, UK
    Posts
    31
    Sorry, Martin! That was my mistake...

    Once in YaST, you need to choose "Software Management". Then type "kernel-source" into the text box there...

    Sorry for the mix up...

  6. #46
    Linux User martinfromdublin's Avatar
    Join Date
    Dec 2004
    Location
    Dublin, Rep. of Ireland
    Posts
    446
    Ok,I installed the kernel-source but all is yet seem right, here's what I now get;

    martin@linux:~> ls /lib/modules/`uname -r`/build
    arch include include2 Makefile Module.symvers scripts
    martin@linux:~>

    I'm still missing 'config'.....


    Martin
    LINUX: Where do you want to go.......Tomorrow!

    Registered Linux user 396633

  7. #47
    Just Joined!
    Join Date
    Mar 2007
    Location
    North Yorkshire, UK
    Posts
    31
    Actually, you're probably not.

    The file is named ".config". The preceding full-stop means that it's a hidden file.
    If you type "su", then the root password, and do it again. Then you should see hidden files, then.

    But everything seems to be fine so far.

  8. #48
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Quote Originally Posted by falcifer
    If you type "su", then the root password, and do it again. Then you should see hidden files,
    if you want to view Hidden Files, execute 'ls -a' in terminal/konsole OR enable View --> 'Show Hidden Files' in Konqueror or Nautilus.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  9. #49
    Linux User martinfromdublin's Avatar
    Join Date
    Dec 2004
    Location
    Dublin, Rep. of Ireland
    Posts
    446
    Still getting errors.......



    make[5]: *** [/home/martin/folders/ndiswrapper-1.39/driver/crt.o] Error 127
    make[4]: *** [_module_/home/martin/folders/ndiswrapper-1.39/driver] Error 2
    make[3]: *** [_all] Error 2
    make[2]: *** [all] Error 2
    make[2]: Leaving directory `/usr/src/linux-2.6.18.8-0.1-obj/i386/default'
    make[1]: *** [default] Error 2
    make[1]: Leaving directory `/home/martin/folders/ndiswrapper-1.39/driver'
    make: *** [all] Error 2

    It's not possible to paste the entire readout as for some reason the site won't accept it until I delete the first few lines.

    Martin

    EDIT:When I use my Knoppix 5.1.1 live DVD I can get everything to work but distro won't install to the hard drive.Maybe I'll post that issue seperately in the Knoppix forum.
    LINUX: Where do you want to go.......Tomorrow!

    Registered Linux user 396633

  10. #50
    Just Joined!
    Join Date
    Mar 2007
    Location
    North Yorkshire, UK
    Posts
    31
    It would help a lot to know what those first few lines were... you can try posting them with [CODE][/CODE] tags around them.

    From what I can find, the "error 127" could mean that there's some issue with the compiler.
    I don't know if it means it's not installed, or there's just a problem with where it's looking for it.

    I'd suggest going to "Software Management" in YaST again, and checking to make sure that "gcc" is installed.

    And see if you can post those other lines...

Page 5 of 11 FirstFirst 1 2 3 4 5 6 7 8 9 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •