Find the answer to your Linux question:
Results 1 to 6 of 6
Edit: Changed title to make more relevant. See this post. Hello there, I'm following the very helpful tutorial by Oxygen to try and get my desktop wireless card working. I'm ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! nick.platt's Avatar
    Join Date
    Mar 2007
    Location
    Ohio, U.S.
    Posts
    3

    WPA/WPA2-Personal(PSK) Key help


    Edit:Changed title to make more relevant. See this post.

    Hello there,

    I'm following the very helpful tutorial by Oxygen to try and get my desktop wireless card working. I'm running Xubuntu Edgy Eft. This is my first go with Linux, and I'm eager to learn.

    I've unpacked and installed ndiswrapper successfully, and copied over the drivers from the disk that came with the card. I was unable to find out what to do with the A3AB.sys file that came on the disk, but the NetA3AB.inf file installed properly. I continued following instructions, and had nearly made it to the last section, when I ran into a problem. My card works (ie, I found the network I need to connect to), but after entering the SSID and key, the next command provided in the tutorial doesn't work on my machine.

    Here is what my screen reads:
    Quote Originally Posted by terminal
    root@nick: /home/nicholas# iwlist scan
    (skipping lo and eth0)
    wlan0......Scan completed :
    ............. Cell 01 - Address: ....
    ............. ESSID: "secrethouse"
    ............. (skipping a bit more)
    ............. Encryption key: on
    (and so forth on down...)
    root@nick: /home/nicholas# iwconfig wlan0 essid secrethouse
    root@nick: /home/nicholas# iwconfig wlan0 key s:-------------
    root@nick: /home/nicholas# dhcpcd wlan0
    bash: dhcpcd: command not found
    root@nick: /home/nicholas#
    So... any reason my bash wouldn't have this command?
    And is there a way to set up my wireless card without it? Or how can I fix it?


    Thanks so much for your help.

  2. #2
    Just Joined!
    Join Date
    Mar 2007
    Posts
    7
    install dhcpcd
    (apt-get install dhcpcd)

  3. #3
    Linux Guru Juan Pablo's Avatar
    Join Date
    Mar 2006
    Location
    /home/south_america/ecuador/quito
    Posts
    2,064
    You may have dhclient instead of dhcpcd

    dhclient wlan0
    Put your hand in an oven for a minute and it will be like an hour, sit beside a beautiful woman for an hour and it will be like a minute, that is relativity. --Albert Einstein
    Linux User #425940

    Don't PM me with questions, instead post in the forums

  4. #4
    Linux User Oxygen's Avatar
    Join Date
    Jul 2004
    Location
    Hartlepool, England
    Posts
    392
    Yeah, there's many different ways to establish DHCP, Ubuntu generally comes with dhclient, as mentioned above.

    Remember to run it as root (sudo).
    Graham - You'd better Use Linux!

    I'm registerd Linux user #397030. What about you?

  5. #5
    Just Joined! nick.platt's Avatar
    Join Date
    Mar 2007
    Location
    Ohio, U.S.
    Posts
    3
    Is there a difference between sudo and su?
    I've been using su without any problems, and sudo seems more complicated.

    Can you explain sudo a bit for me, as compare to su?

    Thanks for the advice about dhclient. I'll try it out now and let you know what happens.

    Edit: Alright, I gave it a shot (well, several shots), and it doesn't seem to've worked. The "apt-get install dhcpcd" failed to find the dhcpcd package, and the dhclient failed to find...anything. When using "iwlist scan" my wireless router is still shown as the number one cell, so I know that the wireless card I installed is working properly. It's just a matter of connecting.

    Any ideas?

  6. #6
    Just Joined! nick.platt's Avatar
    Join Date
    Mar 2007
    Location
    Ohio, U.S.
    Posts
    3
    I started everything over (right down to reinstalling the OS), as I wanted a fresh slate now that I've got a (slightly) better understanding of what to do. Rather than the tutorial by Oxygen, I folled the installation instructions directly on the ndiswrapper wiki, which led me through a mostly similar process but with a few key differences.

    In the end, I've got the card under the ath0 title now, rather than wlan0, and everything appears to be correct except for the WPA encryption key. I've no way of knowing whether that's right or not, becuase it's encrypted, and the command isn't very specific when setting it.

    This is what I've got set up:
    Code:
    root@nick: /home/nicholas/downloads/ndiswrapper-1.38# iwlist ath0 scan
    ath0       Scan completed :
               Cell 01 - Address: 00:17:3F:02:78:22
               ESSID:"secrethouse"
               Protocol:IEEE 802.11g
               Mode:Managed
               Frequency:2.412 GHz (Channel 1)
               Quality:65/100   SIgnal level:-54 dBm   Noise level:-96 dBm
               Encryption key:on
               Bit Rates:....
               IE: WPA Version 1
                   Group Cipher : TKIP
                   Pairwise Ciphers (2) : CCMP Tkip
                   Authentication Suites (1) : PSK
               IE: IEEE 802.11i/WPA2 Version 1
                   Group Cipher : TKIP
                   Pairwise Ciphers (2) : CCMP Tkip
                   Authentication Suites (1) : PSK
    root@nick: /home/nicholas/downloads/ndiswrapper-1.38# iwconfig ath0
    ath0       IEEE 802.11b    ESSID: "secrethouse"
               Mode:Managed  Frequency:2.412 GHz   Access Point: Not-Associated
               Bit Rate: 54 Mb/s
               Encryption key: ####-####-####-####   Security mode:restricted
               Power Management:off
               Link Quality:0   Signal level:0   Noise level:0
               Rx invalid nwid:0 Rxinvalid crypt:0 Rx invalid frag:0
               Tx excessive retries:0   Invalid misc:0   Missed beacon:0
    root@nick: /home/nicholas/downloads/ndiswrapper-1.38# iwconfig ath0 key ###
    Error for wireless request "Set Encode" (8B2A)  :
         invalid argument "###".
    root@nick: /home/nicholas/downloads/ndiswrapper-1.38# dhclient ath0
    Internet Systems Consortium DHCP Client V3.0.4
    Copyright 2004-2006 Internet Systems Consortium.
    All rights reserved.
    For info, please vsit http://www.isc.org/sw/dhcp
    
    Listening on LPF/ath0/00:15:e9:3f:80:e7
    Sending on   LPF/ath0/00:15:e9:3f:80:e7
    Sending on   Socekt/fallback
    DHCPDISCOVER on ath0 to 255.255.255.255 port 67 interval 4
    DHCPDISCOVER on ath0 to 255.255.255.255 port 67 interval 5
    DHCPDISCOVER on ath0 to 255.255.255.255 port 67 interval 6
    DHCPDISCOVER on ath0 to 255.255.255.255 port 67 interval 12
    DHCPDISCOVER on ath0 to 255.255.255.255 port 67 interval 17
    DHCPDISCOVER on ath0 to 255.255.255.255 port 67 interval 16
    DHCPDISCOVER on ath0 to 255.255.255.255 port 67 interval 1
    No DHCPOFFERS received.
    No working leases in persistent database - sleeping.
    So, being that the first cell received in the "iwlist ath0 scan" is the correct one, and all other information seems to be accurate, there must be something wrong with the encryption. Right?

    If so, any advice?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •