Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
How do I config my wireless in Kubuntu? The sytem settings sees my hardware (after using ndiswrapper) but I don't know how to set up my network. Do I need ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! rasch15's Avatar
    Join Date
    Feb 2007
    Location
    Provo
    Posts
    99

    config wireless in Kubuntu


    How do I config my wireless in Kubuntu? The sytem settings sees my hardware (after using ndiswrapper) but I don't know how to set up my network. Do I need to set values for ESSID and all that stuff?

  2. #2
    Just Joined!
    Join Date
    Oct 2004
    Location
    California
    Posts
    36

    Lightbulb Kubuntu wlan config

    Hey rasch15,

    Kubuntu is pretty good at hardware detection, so if you have your card up and powered on, and it shows up as hardware you are doing good. If you are connecting to a wireless network say at home, where you know the essid and the password to connect, if required, you should click "System" on the menu bar at the top of your desktop, then "Administration", then "Networking". When it loads the list of network devices, if you have a WLAN card, or wireless card that shows up, click on the card, and then click "Configure" or "Properties". I can't remember which one is in Kubuntu, i am using Ubuntu. Then when it comes up, make sure the box is checked that says "Enable this connection", then you can type the essid name, which I think is case sensitive, so make sure to capitalise anything that is needed. Then select which key type, most are hexadecimal i think. The 3 networks that I connect to are. Then if you have a WEP key, or password to connect to it, type that in the appropriate box. If your wireless network uses DHCP, where you are automatically assigned an IP address, down below your essid and WEP key settings you should change "Configuration" to DHCP. If your machine has a static IP address, then enter your needed information. If you don't know what that means, then try DHCP first. If all goes ok, click "ok", and the network should reload itself, and take you back to the network settings where it shows your devices. Below your list of devices it MAY or MAY NOT say "Default gateway device" depending on your version of Kubuntu. If it does, change it to the wireless card, usually listed as wlan0 (thats a zero). Then click ok on the main network settings window, and the network will probably reload the network state. And you will know whether or not you can connect to your network.

    If you are connecting to a network where you do not know the essid, like a public hotspot such as starbucks or barnes and noble, or some other, then you may need to use a utility such as "Wireless Assistant". It will scan for networks, and list them. and if you click the one you want and click connect, it will prompt you for a password if needed. Wireless Assistant should be under Applications, Internet from your Menu bar above your desktop. I am pretty sure it is installed by Kubuntu by default. If it is not, or you don't seem to have it, you can connect to the internet some other way, and go to Applications, Add/Remove software, and search for it, or go to System, Administration, Synaptic Package manager, and search for it. If you can install it that way it should help.

    If you know your essid and the password if required, you can type it in in the network settings menu as I explained above.

    If you don't know your settings, and need to scan, try wireless assistant. You may have to run wireless assistant as root. you can open a terminal and type "sudo wlassistant" to launch it, if you have it installed. You can also try other programs to scan for networks, that is just the one that I am familiar with.

    I hope I could be of some help to you. Its frustrating if you are new to linux, and wireless support under linux is never usually easy.


    Good luck, let me know if you need more info.

    -Eric-

  3. #3
    Just Joined! rasch15's Avatar
    Join Date
    Feb 2007
    Location
    Provo
    Posts
    99
    i don't know the essid, and the router is unsecured. Wlassistant does not help becaue it can't find any networks. However, right now I'm on it on my Windows drive. Is there any way I could find the ESSID and WEP on Windows? Or can I enter in the default gateway (192.168.1.1). I don't know if it makes any difference, but my wireless card's device name is eth2, as opposed to wlan0. Thanks for your help

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru Juan Pablo's Avatar
    Join Date
    Mar 2006
    Location
    /home/south_america/ecuador/quito
    Posts
    2,064
    We need way more info to help you, first, are you sure you need to use ndiswrapper?
    post the output of lspci
    post the output of iwconfig
    post the output of ifconfig
    Put your hand in an oven for a minute and it will be like an hour, sit beside a beautiful woman for an hour and it will be like a minute, that is relativity. --Albert Einstein
    Linux User #425940

    Don't PM me with questions, instead post in the forums

  6. #5
    Just Joined!
    Join Date
    Oct 2004
    Location
    California
    Posts
    36

    Lightbulb

    Well... if the router is unsecured, then there is not going to be a key or password that you have to enter. So that helps a little, but Wireless Assistant needs to be run as root, basically with adminstrator privileges. If you open a terminal/command prompt, under Applications, Accessories, Terminal. Type "sudo wlassistant" to run the program as root. If that still doesn't find any available networks when it scans, then your card might not be configured right. If you can connect to the wireless network from windows, then you should be able to see the essid name. Usually down in the lower right corner of your screen near the clock there is a little icon for wireless connections. It looks like a computer screen with lines around it. I'm sure you know what it looks like. I would double click on that to open up your wireless connection settings, and see if you can find the essid name. It might be called something other than essid, it might be the name of the network. You will have to forgive me, i don't use windows very often, and when I do it isn't with wireless. If you have the wireless icon in windows, and you can open it, look for a name of the network. Mine at home is 2WIRE, because I have a 2WIRE brand router. The coffee shop I am in right now is ATTWIFI, because its an at&t access point. But it could be also named something different depending on where you are. Either way, when you open the wireless settings, there are only so many options of possible network names, look for something that might be related to where you are accessing it at. If its at school, look for something like "School" network, or something related. If you can open your wireless settings in windows, take a screenshot and email it to slap20@hotmail.com and maybe I can see the network name if you are not recognizing it.

    I don't know if the command still works in newer versions of windows, but if you click on the start menu and go to "run" in windows, type "cmd" and hit enter, that will open a command prompt in windows, then type "ipconfig /all" and see if the output gives you any clues to the wireless essid.

    If your card is configured right in Kubuntu, and its searching for networks, you should be able to type in the essid and have it connect. Even if wireless assistant isn't cooperating. Does your card have lights that light up when it is powered on or searching for networks in Kubuntu?

    Also in Kubuntu try opening a terminal, and type in "iwconfig", and copy and paste the output here if possible. Mine looks like:
    ----------------------------------------------------------------------------------------------------
    eric@thinkpad-ubuntu:~$ iwconfig
    lo no wireless extensions.

    irda0 no wireless extensions.

    wlan0 802.11b linked ESSID:"attwifi"
    Mode:Managed Frequency:2.462 GHz Access Point: 00:0F:90:18:40:80
    Bit Rate=11 Mb/s Sensitivity=80/85
    Retry:on Fragment thr:off
    Power Management:off
    Link Quality:89/100 Signal level:-57 dBm Noise level:-245 dBm
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:0 Missed beacon:0

    sit0 no wireless extensions.

    eric@thinkpad-ubuntu:~$
    -----------------------------------------------------------------------------------------------

    That might help me identify any errors that your card might be having, or if its not recognized correctly. I should have also asked sooner, but what make and model is your card? For example, mine is D-link brand, and model is DWL-650. Its old and only 11Mbs, as opposed to newer 54 and faster cards, but it works, and is fine for surfing and everyday stuff.

    I hope i'm not rambling to much here, but I am trying to cover all possibilities. Please try what I have suggested above, and let me know how it goes. Good luck.

    -Eric-

  7. #6
    Just Joined! rasch15's Avatar
    Join Date
    Feb 2007
    Location
    Provo
    Posts
    99
    okay, so first of all my card is a usb Dell Truemobile 1300. I used 'lsusb' insteald of 'lspci' because I knew that my card was a usb. Anyway, in answer to both of your requests:

    @Juan Pablo
    Here's the output of what you asked:

    david@david-desktop:~$ lsusb
    Bus 002 Device 001: ID 0000:0000
    Bus 001 Device 004: ID 0930:653d Toshiba Corp.
    Bus 001 Device 003: ID 413c:8102 Dell Computer Corp.
    Bus 001 Device 002: ID 0409:0059 NEC Corp. HighSpeed Hub
    Bus 001 Device 001: ID 0000:0000
    david@david-desktop:~$ iwconfig
    lo no wireless extensions.

    eth0 no wireless extensions.

    eth2 IEEE 802.11b ESSID:"linksys"
    Mode:Managed Channel=6 Access Point: 00:13:10:4C:CB:61
    Sensitivity=0/200
    Link Quality:0 Signal level:0 Noise level:0
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:0 Missed beacon:0

    sit0 no wireless extensions.

    david@david-desktop:~$ ifconfig
    eth0 Link encap:Ethernet HWaddr 00:EE:B0:00D:8E
    inet addr:169.254.38.79 Bcast:169.254.255.255 Mask:255.255.0.0
    inet6 addr: fe80::2ee:b0ff:fe00:dd8e/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:87 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 b) TX bytes:18234 (17.8 KiB)
    Interrupt:10 Base address:0xa000

    eth2 Link encap:Ethernet HWaddr 00:90:4B:75:BD:ED
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:2 errors:0 dropped:0 overruns:0 frame:0
    TX packets:2 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:224 (224.0 b) TX bytes:224 (224.0 b)

    david@david-desktop:~$
    @Norcal_Linux

    umm, I know that the network name is 'linksys'. I tried using KnetworkManager to connect, and here's what the pop-up balloon over wireless connection said:

    Dell Computer Corp. USB Vendor Specific Interface
    Device: eth2
    IP: 0.0.0.0
    Hardware Address: 00:90:4B:75:BD:ED
    Subnet Mask: 0.0.0.0
    Broadcast: 0.0.0.0
    Network: linksys
    Hidden: no
    Access Point: 00:13:10:4C:CB:61, 00:14:BF:34:7B:9C, 00:14:BF:BA:10:A6
    Bandwidth: 62 Mb/s
    Signal Strength: -1
    Frequency: 0.000 GHz
    Encrypted: no
    Device Active: no
    Network Active: no
    also, ill email you some pictures of the network settings so you see what I have to work with in Kubuntu. (the results of iwconfig are above)


  8. #7
    Just Joined! rasch15's Avatar
    Join Date
    Feb 2007
    Location
    Provo
    Posts
    99
    i meant to mention this earlier, but one thing i found strange is that in the results of 'ifconfig' it showed eth2 as being ethernet, not wireless:

    eth2 Link encap:Ethernet HWaddr 00:90:4B:75:BD:ED

    also, i just thought i should let you know, in the results of 'iwconfig' where it says the ESSID is "linksys", that's because I entered linksys, I wasn't able to scan and find the network called linksys (that's what I connect to on Windows)

  9. #8
    Just Joined!
    Join Date
    Oct 2004
    Location
    California
    Posts
    36
    Ok, a couple things. I'm not too worried that your wireless device is called "eth2", because when you run iwconfig it lists it as a wireless device. So it should be recognizing it ok. If when your in windows the access point is called "linksys" make sure to capitalize any letters when typing it in Kubuntu, that are capitalized in windows. So if it was Linksys in windows, type it the exact same way in Kubuntu, Linksys. My Ubuntu laptop wont access my 2WIRE network if I type 2wire. The essid's are usually case sensitive.

    I did a google search on your dell wifi, and it lists it as being supported under linux with ndiswrapper, so assuming all went well when you used the wrapper, it should be working well.

    If your ethernet card eth0 is connecting to the internet in kubuntu, with dhcp, then your wireless should be using dhcp also. Which it appears is ok by looking at your pictures. So that should be ok.

    Nothing looks like its set up incorrectly, as far as what you sent me in the pictures. And the output of your ifconfig, iwconfig, lsusb, all appear not to show any obvious errors.

    Keep trying, and make sure if part of the linksys name is capitalized, that you type it the same way in linux. Try some other forums, google search for using your card in kubuntu, or google a linux user group in your area. I am kind of out of suggestions at the moment. I will have to give it some more thought. Feel free to post back on here, or e-mail me at the e-mail address you sent the pictures to if you have more/different questions, or if something changes.

    I have a belkin wireless usb stick, and it will power up, find a driver (although it is the wrong one), and search for a network, but will never connect. So you might check to make sure you are using the right driver file when you use ndiswrapper. I could never get the belkin to work, so I got a different card. But it seems like yours is working ok, and seems close to being able to connect, so I am kind of puzzled as what to try next.


    -Eric-

  10. #9
    Just Joined! rasch15's Avatar
    Join Date
    Feb 2007
    Location
    Provo
    Posts
    99
    just one thing. THe card itself has 2 LEDs. One is on to show it's connected, and (in WIndows) the other blinks as it searches for networks and as it receives and sends information. When I use it in linux, the 2nd LED never blinks, not while searching for a network or anything. I don't know if that's just because of the operating system, or it's not working right. Anyway, that's about it. Other than the drivers I used were from the cd for the card, and ndiswrapper recognizes the hardware to go with the driver, but that's it for now. Thanks for your help.

  11. #10
    Just Joined!
    Join Date
    Oct 2004
    Location
    California
    Posts
    36
    --"just one thing. THe card itself has 2 LEDs. One is on to show it's connected, and (in WIndows) the other blinks as it searches for networks and as it receives and sends information. When I use it in linux, the 2nd LED never blinks, not while searching for a network or anything. I don't know if that's just because of the operating system, or it's not working right. Anyway, that's about it. Other than the drivers I used were from the cd for the card, and ndiswrapper recognizes the hardware to go with the driver, but that's it for now. Thanks for your help."--

    I think that the 2nd led light, should still blink in linux when searching for a network or to show some kind of activity. If you used the driver cd for the card with ndiswrapper, i'm not real sure why it would not be working. You can try to google some ndiswrapper commands, and see what you can find. I think you can try "sudo ndiswrapper -l" to show a list of drivers installed, and it should say hardware present next to it. I know when I tried to use my belkin usb it would plug in and after using ndiswrapper and some other utilities, I could only get it to light up, not search. Oh, you should also open a terminal and try "sudo iwlist scan" , that should show you a list of networks available, if your card will search. You might try searching google for something like "kubuntu and model_of_your_card" to see if someone has had the same problem, and maybe an easy solution. I will see what I can round up for answers.

    -Eric-

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •