Find the answer to your Linux question:
Results 1 to 4 of 4
Hi all, I have been trying to fix a problem for days. I am using Fedora Core 6 with the latest kernel 2.6.20-1.2925.fc6. I installed ndiswrapper and when I use ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2005
    Posts
    7

    Unhappy D-Link DWL_G132 (A2) + ndiswrapper problem NEED HELP PLZ!!!


    Hi all,

    I have been trying to fix a problem for days. I am using Fedora Core 6 with the latest kernel 2.6.20-1.2925.fc6. I installed ndiswrapper and when I use ndiswrapper -l it says:
    neta5agu : driver installed
    This is the latest driver for the D-LINK DWL-G132 USB wireless stick. I was able to connect to internet once. When I shutdown the PC, the dmesg log says that it cannot halt the usb, PC shutsdown but I still see the LEDs are ON on the device. After I reboot the system, it just hangs. So, I decided to unplug it and plug it back in when the system loads but no luck, system just freezes.

    Now, I can't use the device at all. When I plug-in the device, system freezes immediately. I tried 'rmmod' to remove the ndiswrapper module and plugged in the device and typed 'lsusb' and I saw the device in the list. However, when I used 'modprobe ndiswrapper' system crashed again.

    In the installation instructions for ndiswrapper in Fedora for kernels 2.6.x it was mentioned that 4k kernel stack size might create a problem. There is a link to another site to download kernels with 16k stack size. However I cannot install them since my kernel version is higher then the ones that are listed there. I beleive that this "stack size" thing might be the problem.
    I got so frustrated and hoping that I can get a response from you guys. Thanks in advance for your reply.

  2. #2
    Just Joined!
    Join Date
    Mar 2006
    Posts
    21
    if you're using yum, you can actually uninstall the current kernel and kernel-source, then install a new one right after. You'll have to remember the packages that are also removed due to dependency issue.

    I've done that once due to architecture error .

    As for the wireless driver problem. I just wonder did you use "-a" option to lock the device's id as mentioned in official wiki ?

  3. #3
    Just Joined!
    Join Date
    Nov 2005
    Posts
    7
    Well, I checked the kernel-header version and the kernel version and they match. I already mentioned that I use the latest kernel. I also tried to lock the device id with -a parameter, using the lsusb's output as device id, but no luck. Sometimes, very rarely, I can connect to internet, but kernel always freezes when I use 'rmmod' to remove ndiswrapper.
    So the system can never halt the usb while shutdown. I also suspect that the system gets slower and slower after sometime when connected. Thanks for the reply infwonder.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Mar 2006
    Posts
    21
    Quote Originally Posted by Elgitaro
    I already mentioned that I use the latest kernel.
    Well, I was simply thinking that maybe you can try to re-install same version of kernel with other stack size (not 4k)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •