Find the answer to your Linux question:
Results 1 to 9 of 9
Hi everyone. I'm running Ubuntu 7.04, and I have an Atheros based wi-fi card hence all the ath0-ing going on below. My situation is that the wireless network I need ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2005
    Posts
    5

    Wifi connection keeps dropping - please help!


    Hi everyone.
    I'm running Ubuntu 7.04, and I have an Atheros based wi-fi card hence all
    the ath0-ing going on below. My situation is that the wireless network I need to connect to requires me to use the second key index, which I can do, but then the connection keeps dying.

    Here is how I've got it running on the command line:

    ifconfig ath0 down
    iwconfig ath0 essid <my network name>
    iwconfig ath0 ap <my access point's mac address>
    iwconfig ath0 key [2] <my WEP key>
    iwconfig ath0 key [2]
    iwconfig ath0 key open
    iwconfig ath0 key on
    ifconfig ath0 up
    dhclient ath0
    ping www.google.com (pings are returned)


    The problem: the connection drops after about 10 seconds unless I keep it alive by pinging somewhere.

    Have I done something wrong, or is it something to do with the access point? It's not a signal strength problem - iwconfig lists near perfect signal quality and I'm right next to the AP.

    Thanks.

  2. #2
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,628
    Hi meglamaniac...

    Hmmm. That's a shame. I have become a big believer in atheros for Linux because with the MadWifi driver they have been working so rock solid for me. I don't use hex so have never run into this... It is possible that another version of the driver might make the difference. I wish I knew how to help you better. Sorry.
    Linux Mint + IceWM Registered:#371367 New Members: click here

  3. #3
    Just Joined!
    Join Date
    Dec 2005
    Posts
    5
    Well I've done some troubleshooting and I think I'm getting somewhere.

    So long as I'm not in Gnome (GDM is loaded and running on tty7 but Gnome itself isn't) then the procedure I outlined above works fine - the connection never drops. This obviously isn't very useful though, because then I don't have access to Firefox or anything like that.

    If I try it in Gnome, it always drops sooner or later even if I keep pinging.
    I thought it might have something to do with networkmanager so I tried to find out how to stop it, but I couldn't find an "official" way and I'm not sure where in the boot process it's being loaded. It's not running as a service - "stop NetworkManager" doesn't work.

    So in the end I just killed both the running processes for it which seemed to improve things slightly, but then it still dropped after a couple of minutes.


    This is definately something to do with Gnome, I just don't know what...

  4. #4
    Linux Guru budman7's Avatar
    Join Date
    Oct 2004
    Location
    Knee deep in Grand Rapids, Michigan
    Posts
    3,242
    I just used the commands that you gave with the exception that I skipped putting the mac address in and using the [2] before the key.
    The connection seems to be fine to me.

    I have an Atheros Communications, Inc. AR5005G 802.11abg NIC (rev 01) card.
    How to know if you are a geek.
    when you respond to "get a life!" with "what's the URL?"
    - Birger

    New users read The FAQ

  5. #5
    Just Joined!
    Join Date
    Dec 2005
    Posts
    5
    Ok there is another network on this site which is unsecured. I just tried connecting to it manually but within Gnome, and it works and doesn't drop.

    Then I tried connecting to the one I use again and it dropped.

    I'm wondering if this has something to do with the fact that we don't broadcast our SSID.
    Obviously whichever bit of gnome is interfering here should be able to deal with a network with a hidden SSID, but maybe it can't for some reason. Maybe this is a bug?

    Oh I should probably have pointed out before that the same laptop and card works fine on this network under windows.

  6. #6
    Just Joined!
    Join Date
    May 2007
    Posts
    3
    Quote Originally Posted by meglamaniac View Post
    Hi everyone.
    I'm running Ubuntu 7.04, and I have an Atheros based wi-fi card hence all
    the ath0-ing going on below. My situation is that the wireless network I need to connect to requires me to use the second key index, which I can do, but then the connection keeps dying.

    Here is how I've got it running on the command line:

    ifconfig ath0 down
    iwconfig ath0 essid <my network name>
    iwconfig ath0 ap <my access point's mac address>
    iwconfig ath0 key [2] <my WEP key>
    iwconfig ath0 key [2]
    iwconfig ath0 key open
    iwconfig ath0 key on
    ifconfig ath0 up
    dhclient ath0
    ping Google (pings are returned)


    The problem: the connection drops after about 10 seconds unless I keep it alive by pinging somewhere.

    Have I done something wrong, or is it something to do with the access point? It's not a signal strength problem - iwconfig lists near perfect signal quality and I'm right next to the AP.

    Thanks.
    What Windows are you using? I know that before XP SP2 came out, the default wireless handling of XP was GARBAGE... it would constantly do the same thing that yours is doing. Although, have you tried powering down your router and powering it back up again?

  7. #7
    Just Joined!
    Join Date
    May 2007
    Posts
    3
    needs reply!
    so that I can think about rendering help!

  8. #8
    Just Joined!
    Join Date
    May 2007
    Posts
    3
    oh man no response! why?
    are you all sleeping?

  9. #9
    Just Joined!
    Join Date
    Dec 2005
    Posts
    5
    Hi guys, sorry I must have missed the emails about the first two replies somehow.

    Anyway, basically the problem was networkmanager - if I uninstalled the package in synamptic then everything started behaving. Sometime I'll get around to figuring out how to disable it on startup instead of uninstalling but this'll do for now.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •