Find the answer to your Linux question:
Results 1 to 2 of 2
Hey all, I just switched from Windows to Ubuntu 7.04, and this is my first time using any Linux distro. I understand Atheros cards need MadWifi, and I followed all ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2007
    Posts
    1

    Atheros wireless problem in Ubuntu 7.04


    Hey all,
    I just switched from Windows to Ubuntu 7.04, and this is my first time using any Linux distro. I understand Atheros cards need MadWifi, and I followed all the step by step instructions, including Universe and Multiverse activation, but I still can't recognize any wireless networks. I'm on an Acer Aspire 5570Z with an Atheros 5002 series internal wireless pci.

    ifconfig
    ath0 Link encap:Ethernet HWaddr 00:19:7D:51:A3:4B
    inet6 addr: fe80::219:7dff:fe51:a34b/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

    ath0:avah Link encap:Ethernet HWaddr 00:19:7D:51:A3:4B
    inet addr:169.254.6.10 Bcast:169.254.255.255 Mask:255.255.0.0
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

    eth0 Link encap:Ethernet HWaddr 00:16:367:1E:8B
    inet addr:76.189.126.216 Bcast:255.255.255.255 Mask:255.255.224.0
    inet6 addr: fe80::216:36ff:fed7:1e8b/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:403398 errors:0 dropped:0 overruns:0 frame:0
    TX packets:42979 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:92271583 (87.9 MiB) TX bytes:4741148 (4.5 MiB)
    Interrupt:16

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:4 errors:0 dropped:0 overruns:0 frame:0
    TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:200 (200.0 b) TX bytes:200 (200.0 b)

    wifi0 Link encap:UNSPEC HWaddr 00-19-7D-51-A3-4B-00-00-00-00-00-00-00-00-00-00
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:91925 errors:0 dropped:0 overruns:0 frame:172139
    TX packets:2520 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:199
    RX bytes:6616700 (6.3 MiB) TX bytes:115920 (113.2 KiB)
    Interrupt:18



    also, ethernet works, just not wireless

  2. #2
    Just Joined!
    Join Date
    May 2005
    Posts
    21
    If you are using the Ubuntu Wifi-Gui (how can this thing be stable? its just not working...) try the following:
    Code:
    sudo sh
    ifconfig ath0 up
    iwlist ath0 scan
    iwconfig ath0 essid "Mynetwork" key "horsthorsthorst"
    dhclient ath0
    of course this works not with wpa secured networks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •