Find the answer to your Linux question:
Results 1 to 7 of 7
ok, well im not new to Linux, but i do still struggle sometimes... so here is my problem, i am running Fedora 7, and i have a linksys wireless WUSB54GSC ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! GuitarMaster83's Avatar
    Join Date
    Jun 2007
    Posts
    14

    Exclamation HELP!! installing driver for USB adapter (F7)


    ok, well im not new to Linux, but i do still struggle sometimes... so here is my problem, i am
    running Fedora 7, and i have a linksys wireless WUSB54GSC USB adapter (chip set- Ralink) and i have tried to install some drivers (like the RT73) in tar ball, .gz .bz2 .tar... etc. I follow the instructions but for me errors come up and stuff, like no such file, or cannot create module or whatever. Please walk me through the steps!

    help would be very appreciated!!

    AIM- GuitarMaster5101 (if you can aim me it would be easier!)

    Thanks in advance,
    GuitarMaster

  2. #2
    Linux User Oxygen's Avatar
    Join Date
    Jul 2004
    Location
    Hartlepool, England
    Posts
    392
    When you complain about errors, be sure to actually post them
    Graham - You'd better Use Linux!

    I'm registerd Linux user #397030. What about you?

  3. #3
    Just Joined! GuitarMaster83's Avatar
    Join Date
    Jun 2007
    Posts
    14
    here is the README that came with the file...


    ==================
    Build Instructions
    ==================

    1. Unpack the driver sources and go to the Module directory:
    $ tar -xvzf rt73-cvs-daily.tar.gz
    $ cd ./rt73-cvs-YYYYMMDDHH/Module

    2. Compile the driver sources:
    $ make

    3. Install the driver (as root):
    # make install

    4. Check your install (load module, bring interface up and scan):
    # modprobe rt73
    # ifconfig wlan0 up
    # iwlist wlan0 scan

    If everything is ok, you should see a list of surrounding Access Points. It
    means you can jump to the configuration section.
    Otherwise, check out the following install notes...



    here is what happens to me...
    [*****@localhost ~]$ tar -xvzf rt73-cvs-daily.tar.gz
    rt73-cvs-2007062009/
    rt73-cvs-2007062009/FAQ
    tar: rt73-cvs-2007062009/FAQ: Cannot open: File exists
    rt73-cvs-2007062009/THANKS
    tar: rt73-cvs-2007062009/THANKS: Cannot open: File exists
    rt73-cvs-2007062009/CHANGELOG
    tar: rt73-cvs-2007062009/CHANGELOG: Cannot open: File exists
    rt73-cvs-2007062009/CVS/
    rt73-cvs-2007062009/CVS/Root
    tar: rt73-cvs-2007062009/CVS/Root: Cannot open: File exists
    rt73-cvs-2007062009/CVS/Repository
    tar: rt73-cvs-2007062009/CVS/Repository: Cannot open: File exists
    rt73-cvs-2007062009/CVS/Entries.Log
    tar: rt73-cvs-2007062009/CVS/Entries.Log: Cannot open: File exists
    rt73-cvs-2007062009/CVS/Entries
    tar: rt73-cvs-2007062009/CVS/Entries: Cannot open: File exists
    rt73-cvs-2007062009/LICENSE
    tar: rt73-cvs-2007062009/CVS: Cannot utime: Operation not permitted
    tar: rt73-cvs-2007062009/LICENSE: Cannot open: File exists
    rt73-cvs-2007062009/Module/
    rt73-cvs-2007062009/Module/auth.c
    tar: rt73-cvs-2007062009/Module/auth.c: Cannot open: File exists
    rt73-cvs-2007062009/Module/rt73.h
    tar: rt73-cvs-2007062009/Module/rt73.h: Cannot open: File exists
    rt73-cvs-2007062009/Module/rt73.bin
    tar: rt73-cvs-2007062009/Module/rt73.bin: Cannot open: File exists
    rt73-cvs-2007062009/Module/rt2x00debug.h
    tar: rt73-cvs-2007062009/Module/rt2x00debug.h: Cannot open: File exists
    rt73-cvs-2007062009/Module/md5.c
    tar: rt73-cvs-2007062009/Module/md5.c: Cannot open: File exists
    rt73-cvs-2007062009/Module/rtusb_data.c
    tar: rt73-cvs-2007062009/Module/rtusb_data.c: Cannot open: File exists
    rt73-cvs-2007062009/Module/rtmp_main.c
    tar: rt73-cvs-2007062009/Module/rtmp_main.c: Cannot open: File exists
    rt73-cvs-2007062009/Module/rt_config.h
    tar: rt73-cvs-2007062009/Module/rt_config.h: Cannot open: File exists
    rt73-cvs-2007062009/Module/assoc.c
    tar: rt73-cvs-2007062009/Module/assoc.c: Cannot open: File exists
    rt73-cvs-2007062009/Module/CVS/
    rt73-cvs-2007062009/Module/CVS/Root
    tar: rt73-cvs-2007062009/Module/CVS/Root: Cannot open: File exists
    rt73-cvs-2007062009/Module/CVS/Repository
    tar: rt73-cvs-2007062009/Module/CVS/Repository: Cannot open: File exists
    rt73-cvs-2007062009/Module/CVS/Entries
    tar: rt73-cvs-2007062009/Module/CVS/Entries: Cannot open: File exists
    rt73-cvs-2007062009/Module/wpa.c
    tar: rt73-cvs-2007062009/Module/CVS: Cannot utime: Operation not permitted
    tar: rt73-cvs-2007062009/Module/wpa.c: Cannot open: File exists
    rt73-cvs-2007062009/Module/sync.c
    tar: rt73-cvs-2007062009/Module/sync.c: Cannot open: File exists
    rt73-cvs-2007062009/Module/rtmp_info.c
    tar: rt73-cvs-2007062009/Module/rtmp_info.c: Cannot open: File exists
    rt73-cvs-2007062009/Module/iwpriv_usage.txt
    tar: rt73-cvs-2007062009/Module/iwpriv_usage.txt: Cannot open: File exists
    rt73-cvs-2007062009/Module/rtusb_bulk.c
    tar: rt73-cvs-2007062009/Module/rtusb_bulk.c: Cannot open: File exists
    rt73-cvs-2007062009/Module/mlme.h
    tar: rt73-cvs-2007062009/Module/mlme.h: Cannot open: File exists
    rt73-cvs-2007062009/Module/connect.c
    tar: rt73-cvs-2007062009/Module/connect.c: Cannot open: File exists
    rt73-cvs-2007062009/Module/rtmp_tkip.c
    tar: rt73-cvs-2007062009/Module/rtmp_tkip.c: Cannot open: File exists
    rt73-cvs-2007062009/Module/auth_rsp.c
    tar: rt73-cvs-2007062009/Module/auth_rsp.c: Cannot open: File exists
    rt73-cvs-2007062009/Module/oid.h
    tar: rt73-cvs-2007062009/Module/oid.h: Cannot open: File exists
    rt73-cvs-2007062009/Module/rtmp_init.c
    tar: rt73-cvs-2007062009/Module/rtmp_init.c: Cannot open: File exists
    rt73-cvs-2007062009/Module/TESTING
    tar: rt73-cvs-2007062009/Module/TESTING: Cannot open: File exists
    rt73-cvs-2007062009/Module/rtusb_io.c
    tar: rt73-cvs-2007062009/Module/rtusb_io.c: Cannot open: File exists
    rt73-cvs-2007062009/Module/rtmp.h
    tar: rt73-cvs-2007062009/Module/rtmp.h: Cannot open: File exists
    rt73-cvs-2007062009/Module/mlme.c
    tar: rt73-cvs-2007062009/Module/mlme.c: Cannot open: File exists
    rt73-cvs-2007062009/Module/md5.h
    tar: rt73-cvs-2007062009/Module/md5.h: Cannot open: File exists
    rt73-cvs-2007062009/Module/wpa.h
    tar: rt73-cvs-2007062009/Module/wpa.h: Cannot open: File exists
    rt73-cvs-2007062009/Module/rtmp_wep.c
    tar: rt73-cvs-2007062009/Module/rtmp_wep.c: Cannot open: File exists
    rt73-cvs-2007062009/Module/rtmp_def.h
    tar: rt73-cvs-2007062009/Module/rtmp_def.h: Cannot open: File exists
    rt73-cvs-2007062009/Module/Makefile
    tar: rt73-cvs-2007062009/Module/Makefile: Cannot open: File exists
    rt73-cvs-2007062009/Module/rtmp_type.h
    tar: rt73-cvs-2007062009/Module/rtmp_type.h: Cannot open: File exists
    rt73-cvs-2007062009/Module/sanity.c
    tar: rt73-cvs-2007062009/Module/sanity.c: Cannot open: File exists
    rt73-cvs-2007062009/README
    tar: rt73-cvs-2007062009/Module: Cannot utime: Operation not permitted
    tar: rt73-cvs-2007062009/README: Cannot open: File exists
    tar: rt73-cvs-2007062009: Cannot utime: Operation not permitted
    tar: Error exit delayed from previous errors

    (that is the right file name)

  4. #4
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    I'll throw this in...

    I have a D-Link USB wireless device also with the Ralink chipset and pulled my hair out for weeks trying to get it stable. It would work flawlessly for a day or two... or an hour or two... or a minute or two, then lock my computer down so hard I'd have to cold reboot. I tried several versions of the driver all to no avail, finally giving up trying to get it working under CentOS. Now read my post here for the rest of the story...

    I really don't know what the difference is since both distros are Linux. Perhaps there is some subtle difference in the kernel making the difference, but the boys at Ubuntu are doing something differently and it just works perfectly.

    EDIT: I don't use Fedora anymore, but seems to me I remember it has the Ralink driver already built in to the distro. If so, there is no need to build new module. It's possible that's why you are getting those errors...
    Last edited by Dapper Dan; 06-22-2007 at 03:39 AM.
    Linux Mint + IceWM Registered: #371367 New Members: click here

  5. #5
    Just Joined! GuitarMaster83's Avatar
    Join Date
    Jun 2007
    Posts
    14

    Exclamation

    Well, according to your experience.... its looks like im probably not going to get it to work either, but if you (or anyone else) wants to help me try, please do. i dont really need to install it because i have internet through a cord, but I travel some (my computer is a desktop :o) and some places i go only have WIFI, so i was trying to install the usb adapter for that.

    (if i run Ubuntu through a VM and i plug in the USB adapter, will it install it, like you said in your other posts, and i will be able to use it under Ubuntu? or do i have to have the driver installed through the Host operating system?)

    Thanks,
    GuitarMaster

  6. #6
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    It's been a while since I used a virtual machine so I'm not sure about that either... I think there must be a good "how to" for your device out there somewhere and you just haven't found it. I'll see...

    Struck gold. Not only does this page substantiate to some degree the difficulties I've experienced with Ralink on CentOS (also Red Hat based as is Fedora), but it appears to be a really thorough and easy to follow instruction on how to get your device working properly. I sympathise with your problem and I hope this helps.

    Link

    For what it's worth, the long, difficult and crooked road I've traveled over the years to wirelessness under Linux has led me straight to devices with the Atheros chipset. In my opinion, Atheros with Madwifi is the best way to have an efficient and stable wirless device under Linux.
    Linux Mint + IceWM Registered: #371367 New Members: click here

  7. #7
    Just Joined! GuitarMaster83's Avatar
    Join Date
    Jun 2007
    Posts
    14
    first of all, thanks for the link, but i have some questions...

    --------------------------------------------------------------------------------------------------

    Step 1: Download the latest CVS release of Ralink rt2500 drivers from here.

    Step 2: Unload the kernel module for rt2500 drivers

    [root@bordeaux kulbirsaini] rmmod rt2500pci [Enter]

    Step 3: Go to the directory /lib/modules/2.6.21-1.3194.fc7/kernel/drivers/net/wireless/mac80211/rt2×00 and take backup of the current rt2500pci driver module.

    [root@bordeaux rt2×00] mv rt2500pci.ko back.rt2500pci.ko [Enter]

    Step 4: Untar the download driver tar ball and change to the directory ./rt2500-cvs-XXXXXXXXXX/Module/

    [root@bordeaux Module] make [Enter]

    [root@bordeaux Module] make install-fedora [Enter]

    Step 5: Open /etc/modprobe.conf file and add a line

    ######################

    alias wlan0 rt2500

    ######################

    Save the file and load the rt2500 driver.

    [root@bordeaux kulbirsaini] modprobe rt2500 [Enter]

    Step 6: Go to the directory /etc/sysconfig/network-scripts/ and create a file named ifcfg-wmaster0. Copy the contents of ifcfg-wlan0 to the ifcfg-wmaster0. If you don’t have ifcfg-wlan0 file, then issue command ‘neat’ as root and add new wireless device with appropriate configurations and ifcfg-wlan0 will be created in the process.

    Step 7: Activate the device, what else ???

    PS1 : You can refer to my ifcfg-wlan0 and ifcfg-wmaster0 files.

    PS2 : You can ask for more details on any issues in the any of the above steps.

    ------------------------------------------------------------------------------------------------------------------

    ok, here is what if done so far, ive downloaded, un-tar-ed it (tar -xvzf rt2x00-cvs-daily.tar.gz) and it says undload the kernal module? does he want me to cd the module?

    it says "Step 2: Unload the kernel module for rt2500 drivers" (How? what command?)

    also, "[root@bordeaux kulbirsaini] rmmod rt2500pci [Enter]" (it says command no found, do i have to do step 2 first?)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •