Find the answer to your Linux question:
Results 1 to 3 of 3
The rtl8187 kernel module with Fedora 7 x64 does not appear to allow the card to operate in Master (Access Point) mode only in Managed mode. I know the card ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2007
    Posts
    2

    RTL8187 doesn't work in Master (Access Point) mode


    The rtl8187 kernel module with Fedora 7 x64 does not appear to allow the card to operate in Master (Access Point) mode only in Managed mode. I know the card can operate in this mode since I dual boot Windows XP 64 and it works fine in Windows.
    "iwconfig wlan0 mode Master" succeeds if wlan0 is down (ifconfig wlan0 down)
    and iwconfig then shows wlan0 as being in master mode. However any attempt to activate the connection fails i.e. ifconfig wlan0 up returns:
    "SIOCSIFFLAGS: Operation not supported"

    I then downloaded the drivers from Realtek rtl8187_linux_26.1025.0328.2007 (and for good measure rtl8187B_linux_24.6.1021.0212.2007) however these fail to compile complaining of incompatible pointer types with the final error in both cases being:
    error: ‘struct net_device’ has no member named ‘get_wireless_stats’.

    I then used ndiswrapper and the inf and sys files from my working Windows 64 bit installation with the same result i.e. o.k. in managed can't do master.
    iwconfig wlan0 mode Master returns
    Error for wireless request "Set Mode" (8B06) :
    SET failed on device wlan0 ; Invalid argument.

    Please help. I don't have enough money to buy a router, apart from which I know that the card works fine in this mode (on Windows) (another PC can connect and share this computers internet connection no problem).

  2. #2
    Just Joined!
    Join Date
    Jul 2007
    Posts
    1
    I have not succeeded in setting this card to master mode in linux, not even in windows! How did you do it?

  3. #3
    Just Joined!
    Join Date
    Jul 2007
    Posts
    2
    Sorry for late reply. Had given up on the thread after no reply for a week.
    In Windows since my wireless card is part of the P5B-Deluxe-Wifi motherboard I downloaded the drivers RTL8187_5123005302006.zip from the ASUS website. After installation you get the application ASUS WiFi-AP Solo which has a wizard for setting everything up. You just need to remember to select Access Point mode and not the other one when given the choice and to enable Internet Connection Sharing - done in the wizard or from the ICS tab in the configuration. Saying that I noticed the wireless connection went twice (after the computer had been restarted?) and I had to click again on the Enable Internet Connection Sharing button. I didn't look further at this since I need to get it working in Linux which I use mainly. Now my other computer is sitting unused until I can get it working with Linux or I can get a router. Hope this helps although you've probably already solved your problem by now

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •